Show Menu
THEMEN×

Tabellen erstellen

Sie haben die Möglichkeit, in Berichten je nach anzuzeigenden Daten verschiedene Tabellenarten zu verwenden. Es kann sich dabei um eine Liste mit Gruppierung, eine Tabelle mit Werteverteilung oder um eine über Cube-Messungen erstellte Pivot-Tabelle handeln.

Liste mit Gruppierung erstellen

Eine Liste mit Gruppierung ermöglicht es, bestimmte Daten in der Tabelle zusammenzufassen und Statistiken über die enthaltenen Daten zu erzeugen. Sie können beispielsweise Summen und Zwischensummen erstellen. Jede Gruppierung enthält eine Header-, Detail- und Footer-Zeile.
Der die Tabelle enthaltenden Seite -Aktivität muss eine Abfrage - oder Script -Aktivität vorangehen, um die Daten abzurufen, die im Bericht analysiert werden sollen. Weitere Informationen zu diesen Aktivitäten finden Sie unter Zu analysierende Daten abrufen und Script-Aktivität .

Grundprinzip

Es besteht die Möglichkeit, dass Sie mehrere Datenkategorien gleichzeitig zu analysieren haben. Eine Liste mit Gruppierung ermöglicht es Ihnen, bestimmte Daten zusammenzufassen und Statistiken über unterschiedliche Gruppen in der gleichen Tabelle zu erzeugen. Erstellen Sie hierzu eine Gruppierung in der Tabelle.
Im unten stehenden Beispiel werden mithilfe der Gruppierung die Gesamtheit aller Kampagnen der Datenbank, die Sendungen und die Anzahl der pro Versand und pro Kampagne versendeten Nachrichten angezeigt.
Sie ermöglicht es, die Liste der Kampagnen ( Titel (Kampagne) ) und die Liste der zur Kampagne gehörenden Sendungen ( Titel ) zu verzeichnen sowie die Anzahl an pro Versand versendeten Nachrichten zu zählen ( Verarbeitet ) und sie für jede Kampagne zu addieren ( Sum(@processed) ).

Umsetzung

Ein Beispiel für die vollständige Implementierung finden Sie hier: Anwendungsbeispiel: Bericht mit einer Liste mit Gruppierung erstellen .
Im Folgenden werden die Etappen zur Erstellung einer Tabelle vom Typ "Liste mit Gruppierung" kurz zusammengefasst:
  1. Gehen Sie zur Grafik des Berichts und platzieren Sie eine Abfrageaktivität . Siehe Zu analysierende Daten abrufen .
  2. Geben Sie die Quelltabelle an und wählen Sie die Felder der Tabelle aus, auf die sich die Statistiken beziehen sollen.
  3. Platzieren Sie eine Seitenaktivität in der Grafik. Weitere Informationen finden Sie unter Statische Elemente .
  4. Fügen Sie ein Diagramm vom Typ Liste mit Gruppierung in die Seite ein.
  5. Geben Sie den Pfad der Daten an, also die als Datenquelle in der Abfrage gewählte Tabelle.
    Diese Etappe ist zwingend erforderlich, um die Felder der Quelltabelle zu finden und sie in die Zellen der Tabelle einzufügen.
  6. Erstellen Sie die Tabelle und Ihren Inhalt.
  7. Überprüfen Sie im Tab Vorschau den erstellten Bericht. Er kann nun publiziert und bei Bedarf in einem anderen Format exportiert werden. Weitere Informationen finden Sie unter Berichtexport .

Zeilen und Spalten hinzufügen

Eine Tabelle vom Typ Liste mit Gruppierung besteht standardmäßig aus einer Header-, einer Detail- und einer Footer-Zeile.
Eine Gruppierung enthält selbst ebenfalls eine Header-, eine Detail- und eine Footer-Zeile.
  • Header : erlaubt die Angabe von Spaltentiteln.
  • Detail : enthält die Werte der Statistiken.
  • Footer : erlaubt die Anzeige der Summen der Statistiken.
Sie können beliebig viele Spalten und Zeilen hinzufügen.
Die Gruppierung kann in einer beliebigen Zeile der Tabelle positioniert werden. Sie besteht selbst aus einer Header-, einer Detail- und einer Footer-Zeile.
Um eine Zeile oder eine Spalte hinzuzufügen, markieren Sie eine existierende Zeile oder Spalte und nutzen Sie die jeweiligen Kontextmenüs.
Um zum Beispiel eine Header-Zeile hinzuzufügen, muss der Mauszeiger auf einem Header positioniert und auf Hinzufügen > Zeile oberhalb/unterhalb geklickt werden.
Die Breite der Spalten kann über den Menüpunkt Spaltenformat geändert werden.
Gruppierung : Um eine Gruppierung hinzuzufügen, klicken Sie ebenfalls in eine Zeile und wählen Sie den entsprechenden Punkt im Kontextmenü aus.

Zelleninhalt bestimmen

Um eine Zeile der Tabelle zu bearbeiten und Inhalt und Format zu definieren, klicken Sie in die Zelle und nutzen Sie das Kontextmenü.
Wählen Sie den Menüpunkt Ausdruck , um die anzuzeigenden Werte zu bestimmen.
  • Wenn Sie die zu analysierenden Werte direkt in die Tabelle einfügen möchten, wählen Sie sie unter den verfügbaren Feldern aus.
    Die Liste der verfügbaren Felder entspricht dem Inhalt der Abfrage, die der Tabelle im Berichtdiagramm vorausgeht.
  • Erfassen Sie einen Titel, zum Beispiel in einer Header-Zelle.
    Gehen Sie hierzu vor wie beim Einfügen eines Datenbank-Felds, aber wählen Sie keinen Ausdruck aus. Erfassen Sie den Titel im Feld Titel : Er wird genau so angezeigt.
  • Berechnen Sie ein Aggregat (Durchschnitt, Summe etc.) und lassen Sie es in einer Zelle anzeigen.
    Nutzen Sie hierzu den Menüpunkt Aggregate und wählen Sie die gewünschte Funktion aus.

Zellenformat bestimmen

Um das Zellenformat zu definieren, ermöglicht der Menüpunkt Zellenformat... Zugriff auf alle für die gewählte Zelle verfügbaren Formatierungsoptionen.
Diese Optionen erlauben es, die spätere Darstellung des Berichts anzupassen und die Lesbarkeit der enthaltenen Informationen zu optimieren.
Das Feld Zeilenumbruch ist im Rahmen eines Datenexports im Excel-Format von Nutzen: Wählen Sie den Wert Ja aus, um den Zeilenumbruch zu forcieren. Dieser Wert wird beim Export berücksichtigt. Weitere Informationen finden Sie unter Berichtexport .
Über das Fenster Zellen formatieren erhalten Sie Zugriff auf den folgenden Tab:
  • Den Tab Wert
  • Den Tab Rahmen
  • Den Tab Klick
  • Den Tab Mehr
Im Tab Wert können die Schriftart und die unterschiedlichen Attribute der Werte verändert oder ihnen ein ihrer Art entsprechendes Format zugeteilt werden.
Das Format ändert die Anzeige der Daten: Die Formate Zahl , Währung und Prozent erlauben beispielsweise eine rechtsbündige Anzeige der Ziffern mit Dezimalen.
Konfigurationsbeispiel Währungsformat: Sie können die Währung angeben, in der die Werte ausgedrückt werden, das Tausendertrennzeichen bei Bedarf verwenden und negative Werte in Rot anzeigen. Die Position des Währungssymbols hängt von der Sprache des Benutzers ab, die in seinem Profil festgelegt wurde.
Konfigurationsbeispiel Datumsformat: Bei Bedarf kann die Uhrzeit angezeigt werden.
Im Tab Rahmen können den Zeilen und Spalten der Tabelle Rahmen hinzufügt werden. Die Umrahmung von Zellen kann die Leistung beim Export von umfangreichen Berichten im Excel-Format beeinträchtigen.
Bei Bedarf können Rahmen auch in der Tabellenvorlage hinzugefügt werden ( Administration > Konfiguration > Formular-Rendering ).
Die Syntax lautet in diesem Fall wie folgt:
im Web-Tab:
 .tabular td {
 border: solid 1px #000000;
 }

im Excel-Tab:
 <style name="odd" fillColor="#fdfdfd">
  <border>
   <borderTop value="solid 0.05pt #000000" />
   <borderBottom value="solid 0.05pt #000000" />
   <borderLeft value="solid 0.05pt #000000" />
   <borderRight value="solid 0.05pt #000000" />
  </border>
 </style> 
 
 <style name="even" fillColor="#f7f8fa">
  <border>
   <borderTop value="solid 0.05pt #000000" />
   <borderBottom value="solid 0.05pt #000000" />
   <borderLeft value="solid 0.05pt #000000" />
   <borderRight value="solid 0.05pt #000000" />
  </border>
 </style> 

Im Tab Klick kann definiert werden, welche Aktion der Klick auf den Inhalt einer Zelle der Tabelle ermöglicht.
Im nachstehenden Beispiel wird durch Klick auf die Zelle die zweite Seite des Berichts angezeigt: Sie enthält Informationen bezüglich des in der Zelle enthaltenen Versands.
Mit dem Tab Mehr kann das Layout der Daten ausgewählt werden, zum Beispiel eine Farbplakette oder ein Bargraph. Die Farbplakette wird genutzt, wenn die Tabelle als Legende einer Grafik angezeigt wird. Weitere Informationen finden Sie im Implementierungsbeispiel: 5. Schritt - Zweite Seite konfigurieren

Anwendungsbeispiel: Bericht mit einer Liste mit Gruppierung erstellen

In diesem Beispiel wird ein zweiseitiger Bericht erstellt: Die erste Seite soll die Liste und die Summe der Sendungen pro Kampagne sowie die Anzahl der gesendeten Nachrichten enthalten. Der Titel der Sendungen erhält die Form eines anklickbaren Links und wird den Zugriff auf die zweite Seite des Berichts ermöglichen, um die Verteilung der gesendeten Nachrichten des gewählten Versands pro E-Mail-Domain in einer Tabelle und einer Grafik einzusehen. Auf der zweiten Seite soll die Tabelle als Legende der Grafik dienen.

1. Schritt - Bericht erstellen

Erstellen Sie einen neuen Bericht, der sich auf das Kampagnen-Schema bezieht ( Kampagnen (nms) ).
Klicken Sie auf Speichern .
Positionieren Sie im Bericht die ersten Komponenten zur Erstellung des Inhalts: eine erste Abfrage und eine erste Seite.

2. Schritt - Erste Abfrage konfigurieren

Die erste Abfrage soll die Sendungen aller Kampagnen abrufen.
Doppelklicken Sie auf die erste Abfrage, um sie zu öffnen, und konfigurieren Sie sie folgenderweise:
  1. Ändern Sie zunächst das Schema, auf das sich die Abfrage bezieht: Wählen Sie das Schema Sendungen (nms) .
  2. Klicken Sie auf den Link Abfrage bearbeiten... und aktivieren Sie die Anzeige der erweiterten Felder.
  3. Wählen Sie die folgenden Felder aus:
    • Titel des Versands,
    • Primärschlüssel des Versands,
    • Titel der Kampagne,
    • Indikator der verarbeiteten Sendungen,
    • Fremdschlüssel des Kampagnen-Links,
    • Indikator der Fehlerrate.
    Ordnen Sie jedem Feld einen Alias zu: Dies erleichtert die Auswahl der Daten der Tabelle, die in der ersten Seite des Berichts hinzugefügt wird.
    Im vorliegenden Beispiel werden die folgenden Alias verwendet:
    • Titel: @label
    • Primärschlüssel: @deliveryId
    • Titel (Kampagne): @label1
    • Verarbeitet: @processed
    • Fremdschlüssel der 'Kampagne'-Relation ('id'-Feld) @operationId
    • Fehlerrate: @errorRatio
  4. Klicken Sie zweimal auf die Schaltfläche Weiter bis zur Etappe Datenfilterung .
    Fügen Sie eine Filterbedingung hinzu, um nur die zu einer Kampagne gehörenden Sendungen abzurufen.
    Die Syntax des Filters sollte wie folgt lauten: "Fremdschlüssel der 'Kampagne'-Relation größer als 0".
  5. Klicken Sie zur Speicherung dieser Bedingung auf Beenden und zum Schließen des Abfrage-Editors auf OK .

3. Schritt - Erste Seite konfigurieren

In diesem Schritt wird die erste Seite des Berichts konfiguriert. Gehen Sie wie folgt vor:
  1. Öffnen Sie die Seite -Aktivität und vergeben Sie einen Titel, hier zum Beispiel Sendungen .
  2. Fügen Sie eine Liste mit Gruppierung über die Symbolleiste ein und geben Sie ihr einen Titel, hier zum Beispiel Liste der Sendungen nach Kampagne.
  3. Klicken Sie auf den Link Pfad der Tabellendaten... und wählen Sie den Sendungen-Link aus, also [query/delivery] .
  4. Klicken Sie auf den Tab Daten und vergrößern Sie die Tabelle, indem Sie sie rechts auf insgesamt drei Spalten erweitern.
  5. Fügen Sie eine Gruppierung hinzu.
    Diese Gruppierung wird es ermöglichen, die Kampagnen und die ihnen zugeordneten Sendungen zusammenzufassen.
  6. Referenzieren Sie im Gruppierungsfenster den Fremdschlüssel der 'Kampagne'-Relation und schließen Sie das Fenster.
  7. Bearbeiten Sie die erste Zelle des Gruppierungs-Headers und fügen Sie das Titel -Feld der Kampagnen als Ausdruck ein.
  8. Bearbeiten Sie die zweite Zelle der Detailzeile und wählen Sie das Titel -Feld der Sendungen.
  9. Bearbeiten Sie das Format der Zelle und öffnen Sie den Tab Klick . Konfigurieren Sie die entsprechenden Optionen dahingehend, dass beim Klick auf den Namen eines Versands sich dieser im selben Fenster öffnet.
    Wählen Sie hierzu die Aktion vom Typ Nächste Seite mit der Fensteroption Im selben Fenster .
  10. Klicken Sie im unteren Bereich des Fensters auf Hinzufügen und geben Sie den Pfad /vars/selectedDelivery sowie den Ausdruck @deliveryId an, der dem Alias des Primärschlüssels des Versands entspricht, der in der zuvor erstellten Abfrage definiert wurde. Diese Formel ermöglicht den Zugriff auf den gewählten Versand.
  11. Bearbeiten Sie die zweite Zelle des Gruppierungs-Footers und geben Sie den Titel Gesamt je Kampagne ein.
  12. Bearbeiten Sie die dritte Zelle des Gruppierungs-Headers und geben Sie den Titel Anzahl gesendeter Nachrichten an.
    Diese Information entspricht dem Spaltentitel.
  13. Bearbeiten Sie die dritte Zelle der Detailzeile und wählen Sie als Ausdruck den Indikator "Verarbeitete Nachrichten" aus.
  14. Bearbeiten Sie die dritte Zelle des Gruppierungs-Footers, wählen Sie den Indikator der verarbeiteten Sendungen und teilen Sie ihm das Aggregat Summe zu.
  15. Bearbeiten Sie die vierte Zelle der Detailzeile und wählen Sie den Ausdruck Fehlerrate der Sendungen aus.
  16. Markieren Sie diese Zelle, um die Fehlerrate der Sendungen als Bargraph darzustellen.
    Gehen Sie hierzu in den Tab Mehr des Zellenformats. Wählen Sie dort das Format Bargraph in der Dropdown-Liste aus und aktivieren Sie die Option Zellenwert ausblenden .
    Sie können nun die Vorschau des Berichts im gleichnamigen Tab einsehen. Aktivieren Sie die Option Allgemein : Die Liste aller mit einer Kampagne verbundenen Sendungen aus der Adobe-Campaign-Datenbank wird angezeigt.
    Es wird empfohlen, stets im Vorschau -Tab zu überprüfen, ob die Tabellendaten korrekt ausgewählt und konfiguriert wurden. Nach der Überprüfung können Sie Ihre Tabelle formatieren.
  17. Wählen Sie für die Zellen, die die Gesamtanzahl pro Kampagne und die Summen der verarbeiteten Nachrichten anzeigen, den Stil Fett aus.
  18. Klicken Sie auf die erste Zelle des Gruppierungs-Headers, die den Namen der Kampagne enthält, und wählen Sie Bearbeiten > Nach rechts verbinden .
    Durch die Verbindung der ersten beiden Zellen des Gruppierungs-Headers wird der Abstand zwischen dem Titel der Kampagne und der Liste der ihr zugehörigen Sendungen verkleinert.
    Dieser Vorgang kann nicht rückgängig gemacht werden. Daher wird ausdrücklich empfohlen, Zellen erst dann zu verbinden, wenn die Erstellung des Berichts abgeschlossen ist.

4. Schritt - Zweite Abfrage erstellen

Es werden eine zweite Abfrage und eine zweite Seite hinzugefügt, um die Details eines Versands anzuzeigen, wenn er vom Benutzer des Berichts angeklickt wird. Bevor Sie die Abfrage hinzufügen, öffnen Sie die bereits erstellte Seite und aktivieren Sie die ausgehende Transition, um sie mit der Abfrage verbinden zu können.
  1. Fügen Sie die neue Abfrage nach der Seite -Aktivität ein und wählen Sie als Quellschema die Versandlogs der Empfänger aus.
  2. Öffnen Sie die Abfrage und bestimmen Sie die Ausgabespalten. Um die Anzahl an Sendungen je E-Mail-Domain anzuzeigen, gehen Sie wie folgt vor:
    • Konfigurieren Sie die Zählung der Versandlogs über deren Primärschlüssel:
    • Fragen Sie die E-Mail-Domains der Empfänger ab und aktivieren Sie die Gruppierung für dieses Feld. Aktivieren Sie hierzu die Option Gruppieren der Spalte des Domain-Namens.
    Ordnen Sie den Feldern die folgenden Alias zu:
    • count(Primärschlüssel): @count
    • E-Mail-Domain (Empfänger): @domain
  3. Klicken Sie zweimal auf die Schaltfläche Weiter , bis zum Schritt Datenfilter .
    Fügen Sie eine Filterbedingung hinzu, um nur die mit dem markierten Versand zusammenhängenden Informationen abzufragen.
    Die Syntax lautet wie folgt: Fremdschlüssel der 'Versand'-Relation ist gleich dem Wert dieses Parameters $([vars/selectedDelivery])
  4. Schließen Sie das Konfigurationsfenster der Abfrage und fügen Sie dem Diagramm im Anschluss an die zweite Abfrage eine Seite hinzu.

5. Schritt - Zweite Seite konfigurieren

  1. Öffnen Sie die Seite und vergeben Sie einen Titel, hier E-Mail-Domains .
  2. Deaktivieren Sie die Option Ausgehende Transitionen aktivieren : Diese Seite ist die letzte Aktivität des Berichts.
  3. Fügen Sie eine neue Gruppierungs-Liste mithilfe des Kontextmenüs hinzu und geben Sie ihr den Titel E-Mail-Domains nach Empfängern .
  4. Klicken Sie auf den Link Pfad der Tabellendaten... und wählen Sie die Relation Versandlogs der Empfänger .
  5. Passen Sie die Tabelle im Tab Daten wie folgt an:
    • Fügen Sie rechts zwei zusätzliche Spalten ein.
    • Fügen Sie in der ersten Zelle der Detailzeile den Ausdruck rowNum()-1 hinzu, um die Anzahl der Zeilen zu zählen. Ändern Sie anschließend das Format der Zelle: Wählen Sie im Tab Mehr die Option Farbplakette aus und klicken Sie auf OK .
      Diese Konfiguration ermöglicht es, die Tabelle als Legende für die Grafik zu verwenden.
    • Fügen Sie in der zweiten Zelle der Detailzeile den Ausdruck E-Mail-Domain(Empfänger) hinzu.
    • Fügen Sie in der dritten Zelle der Detailzeile den Ausdruck count(Primärschlüssel) hinzu.
  6. Fügen Sie der Seite über das Kontextmenü ein Kreisdiagramm hinzu und geben Sie ihm den Titel E-Mail-Domains . Weitere Informationen finden Sie unter Grafiktypen und ihre Parameter .
  7. Klicken Sie auf den Link Grafikparameter... und deaktivieren Sie die Optionen Titel anzeigen und Legende anzeigen .
  8. Stellen Sie sicher, dass keine Wertesortierung konfiguriert wurde. Nähere Informationen diesbezüglich erhalten Sie in diesem Abschnitt .
  9. Ändern Sie im Tab Daten die Datenquelle: Wählen Sie Kontextdaten aus der Dropdown-Liste aus.
  10. Klicken Sie dann auf Erweiterte Parameter und wählen Sie die Relation der Empfänger-Versandlogs.
  11. Wählen Sie im Abschnitt Grafiktyp die Variable E-Mail-Domain .
  12. Fügen Sie anschließend die auszuführende Berechnung hinzu: Wählen Sie Summe als Funktion.
  13. Klicken Sie auf die Schaltfläche Detail , um das Feld auszuwählen, auf dass sich die Zählung beziehen soll, und schließen Sie das Konfigurationsfenster der Seite.
  14. Speichern Sie den Bericht.
    Die zweite Seite ist nun konfiguriert.

6. Schritt - Bericht überprüfen

Um das Ergebnis der Konfiguration zu überprüfen, klicken Sie auf den Tab Vorschau und wählen Sie die Option Allgemein aus.
Die erste Seite des Berichts zeigt die Liste aller in der Datenbank enthaltenen Sendungen.
Durch Klick auf den Link einer der Sendungen wird die Verteilung dieses Versands pro E-Mail-Domain angezeigt. Von der zweiten Seite des Berichts können Sie über die entsprechende Schaltfläche auf die vorhergehende Seite zurückkehren.

Verteilungs- oder Pivot-Tabelle erstellen

Dieser Tabellentyp ermöglicht die Anzeige von Statistiken über die Datenbank.
Die Konfiguration derartiger Berichte entspricht der im Assistenten zur deskriptiven Analyse verwendeten. Lesen Sie hierzu diese Seite .
Die Erstellung einer Pivot-Tabelle wird in diesem Abschnitt beschrieben.