Show Menu
THEMEN×

Verwenden von Maven für Communities

Übersicht

Dieser Abschnitt der Dokumentation zu AEM Communities ergänzt:
Es gibt jetzt zwei "Uber"-Artefakte, die einzelne Artefakte ersetzen:

Communities API JAR Artefakt

Im Folgenden finden Sie ein Beispiel für eine GAV für die AEM Communities API-JAR:
<dependency>
    <groupId>com.adobe.cq.social</groupId>
    <artifactId>cq-socialcommunities-api</artifactId>
    <version>1.11.170</version>
    <scope>provided</scope>
</dependency>

Stellen Sie sicher, dass die angegebene Version der Communities-Paketversion entspricht, die für AEM Communities installiert wurde. So überprüfen Sie die installierte Versionsnummer:
  1. Melden Sie sich mit Administratorrechten an.
  2. Suchen Sie das Paket cq-socialgroups-pkg-1.x.xxx
  3. Extrahieren Sie die Version aus dem Paketnamen:
    • Die erste Version von AEM 6.3 ist Version 1.11.170.
    • Feature Packs sind die Versionen 1.12.xxx.
Es wird empfohlen, mit der neuesten Version von Communities auf dem Laufenden zu bleiben.
Im Abschnitt Neueste Versionen finden Sie die neueste Version.

Beispiel für eine Maven-Abhängigkeit

Die Communities API-JAR-Datei muss vor der Uber API-JAR-Datei angegeben werden.
<dependency>
    <groupId>com.adobe.cq.social</groupId>
    <artifactId>cq-socialcommunities-api</artifactId>
    <version>1.11.170</version>
    <scope>provided</scope>
</dependency>
<dependency>
    <groupId>com.adobe.aem</groupId>
    <artifactId>uber-jar</artifactId>
    <version>6.3.0</version>
    <scope>provided</scope>
    <classifier>apis</classifier>
</dependency>