Show Menu
THEMEN×

Fehlerbehebung der AEM Forms-App

In diesem Artikel werden die Fehlermeldungen, die beim Erstellen von AEM Forms App möglicherweise angezeigt werden und die Schritte zur Problembehebung.
Die Abschnitte in diesem Artikel behandeln Folgendes:

Verlust von Anhängen für iOS-Benutzer

AEM Forms-App für iOS, die zur Synchronisierung mit AEM Forms unter OSGi konfiguriert ist, unterstützt nur Anlagen auf Feldebene. Alle Anlagen müssen eindeutige Namen haben. Wenn mehrere Anlagen denselben Namen haben, wird nur eine Anlage beibehalten und alle anderen mit identischem Namen gehen verloren. Führen Sie die folgenden Schritte aus, um Benutzer auf iOS-Geräten vor Datenverlust zu bewahren:
  1. On the connected server, navigate to Adobe Experience Manager > Tools > Operations > Web Console .
  2. Suchen Sie nach Konfigurationsdienst für adaptive Formulare und klicken Sie darauf.
  3. Aktivieren Sie im Konfigurationsdienst für adaptive Formulare Dateinamen individualisieren .
    If Make File Names Unique setting is disabled, users experience data loss if they try to submit adaptive forms with multiple attachments.
  4. Klicken Sie auf Speichern .

Entwürfe von HTML5 -Formularen, die von Workspace-Benutzern eingesendet wurden, werden nicht auf dem Portal angezeigt

For HTML5 forms enabled in AEM Forms app with Save as Draft HTML Render Profile, the saved drafts are not visible to workspace users. So zeigen Sie gespeicherte Entwürfe von HTML5-Formularen an, die von Workspace-Benutzern im Portal übermittelt wurden:
  1. Öffnen Sie CRXDE und melden Sie sich als Administrator an.
    URL: https://<server>:<port>/lc/crx/de/index.jsp
  2. Im Stammpfad von CRXDE, in der Zugriffssteuerungsliste unter Zugriffssteuerung klicken Sie auf + .
  3. Klicken Sie im Dialogfeld Neuen Eintrag hinzufügen auf die Gruppensuche-Schaltfläche im Feld „Prinzipal“.
  4. In the Name field of the Select Principal dialog, type PERM_WORKSPACE_USER and click Search .
  5. Select PERM_WORKSPACE_USER group in the Select Principal dialog and click OK .
  6. Im Dialogfeld „Neuen Eintrag hinzufügen“ wird PERM_WORKSPACE_USER -Gruppe im Feld „Prinzipal“ ausgewählt.
    Enable jcr:read privileges for the user group.
  7. Klicken Sie auf OK .

HTML5-Formulare (nicht zwischengespeichert) werden in AEM Forms App nicht geladen

Wenn AEM Forms App mit einer älteren Version von AEM Forms-Server verbunden ist, können nicht zwischengespeicherte HTML5-Formulare nicht in AEM Forms App hochgeladen werden.
Führen Sie zur Behebung dieses Problems folgende Schritte durch:
  1. Navigieren Sie in der Autoreninstanz zu Adobe Experience Manager > Tools > Workspace-App-Offline-Dienst konfigurieren > Jetzt konfigurieren .
  2. Auf der Seite Workspace-App Offline-Service klicken Sie auf Manueller Ressourcen-Cache .
    URL: https://<server>:<port>/libs/fd/workspace-offline/content/config.html
  3. Im manuellen Ressourcen-Cache klicken Sie auf die Schaltfläche + , um einen CRX-Pfad hinzuzufügen.
  4. In the Add a New Resource field, type: /etc.clientlibs/fd/xfaforms/I18N/en_US.js and click Add .
  5. Klicken Sie auf Speichern .

AEM Forms werden unter Windows nicht synchronisiert

Ein Formular wird unter Windows nicht in der AEM Forms-App mit dem verbundenen Server synchronisiert, wenn der Pfad des Formulars oder seine Ressourcen länger als 256 Zeichen lang sind.
Modifizieren Sie den Pfad des Formulars und seine Ressourcen, um die Anzahl der Zeichen im Pfad auf 256 zu reduzieren.

Nicht unterstützte Version von Gradle

Fehlermeldung: Das Projekt verwendet eine nicht unterstützte Version von Gradle.
Die Fehlermeldung wird angezeigt, wenn Sie die AEM Forms-App in Android Studio erstellen. Das Problem tritt aufgrund einer nicht unterstützten Version von Gradle auf, die vom System unterstützt wird.
Lösung: Klicken Sie auf Korrigieren Sie den Gradle Wrapper und importieren Sie das Projekt erneut, um das Problem zu beheben.

Kompatibilitätsprobleme mit Gradle und Android Gradle Plug-In

Fehlermeldung: Die Versionen des Android-Gradle-Plug-Ins und der Gradle-Funktion sind nicht kompatibel.
The error message is displayed when you select Build APK option from the Build menu on the Android Studio user interface.
Lösung: Öffnen Sie die Datei Gradle Scripts > gradle-wrapper.properties und bearbeiten Sie die Eigenschaft distributionUrl .
For example, the Android Studio console recommends downgrading the Gradle version to 3.5. Edit the version in distributionUrl of gradle-wrapper.properties file.
Select Build > Build APK again to resolve the error and generate the .apk file.