Show Menu
TOPICS×

System requirements

System requirements for HTML5 viewers.

Server hardware and software

  • Dynamic Media Classic Image Serving 6.5.3 or later.
  • HTML5 Viewers require SDK JavaScript server-side libraries 3.7.1 or later.
  • "Email a Friend" social features require s7ondemand 5.0.7 or later.
  • eCatalog Viewer - Info panel support requires info server 2.1.8 or later.
  • Search feature components require s7search 2.3.0 or later.

Viewers system requirements

Client browser minimum requirements for component viewers
  • Color monitor and video card that supports 16-bit High Color at 1024x768 resolution or higher.
  • Microsoft® Windows® 7 or later; Mac OS X 10.9 or later.
  • Firefox 61, Safari 10 (Mac OS only), Chrome 66 (or latest version; Chrome updates automatically to the latest version), Internet Explorer 11, Microsoft Edge.
  • iOS6 or later.
  • Certified on iPhone 3GS or later, and iPad 2 or later (Safari and Chrome browsers only).
  • Android OS 4.x or later.
  • BlackBerry 10 or later; native browsers only. Video playback is only supported at this time.
  • Internet Explorer on mobile devices is not supported at this time.
  • Panoramic viewer is supported on iOS 10 or later, Firefox 61, Chrome 66, Safari 11 or later, Internet Explorer 11 or later, Microsoft Edge, Android 4.4 or later (phone devices only).
  • Video 360 viewer is supported iOS12 or later, Firefox 61, Chrome 66, Safari 12 or later, Microsoft Edge, Android 5 or later (phone devices only).
  • Zoom Vertical viewer is supported on iOS 10 or later, Firefox 61, Chrome 66, Safari 11 or later, Internet Explorer 11, Microsoft Edge, Android 4.x or later.
  • Video viewer does not support HLS (HTTP Live Streaming) playback in Internet Explorer 11 running under Windows 7.
Effective September 30, 2018, Adobe Dynamic Media Classic Viewers is ending support of Transport Layer Security 1.0 (TLS 1.0). As such, Dynamic Media Classic no longer supports viewers on the following browsers and/or platforms that support TLS 1.0. (Adobe Systems recommends the use of TLS 1.2 or later.)
  • Android 2.3.7
  • Android 4.0.4
  • Android 4.1.1
  • Android 4.2.2
  • Android 4.3
  • Internet Explorer 7 on Windows Vista
  • Internet Explorer 8 on Windows XP
  • Internet Explorer 8-10 on Windows 7
  • Internet Explorer 10 on Windows Phone 8.0
  • Safari 5.1.9 on Apple OS X 10.6.8
  • Safari 6.0.4 on Apple OS X 10.8.4
  • Java 6u45
  • Java 7u25
  • OpenSSL 0.9.8y
  • Baidu January 2015
FLASH VIEWERS END-OF-LIFE—Effective January 31, 2017, Adobe Scene7 Publishing System officially ended support for the Flash viewer platform. For more information about this important change, see the following FAQ website: