Show Menu
TOPICS×

Set up environment for AEM Forms app

You need the following hardware, software, and licenses to build and deploy the AEM Forms app:

For Windows devices

  • Microsoft Windows 8.1 or Windows 10
  • Microsoft Visual Studio 2015
  • Microsoft Visual Studio Tools for Apache Cordova

For iOS devices

  • Intel-based Apple Mac running Mac OS X 10.9.5 or above
  • iOS SDK 8.4 or above
  • Xcode version: Xcode 6.4 for OS X or above
  • Membership of the iOS Developer Enterprise program
  • Enterprise certificate for distributing in-house iOS apps
  • Apple iPad with iOS 8.4 or later

For Android devices

  • Android Development Toolkit (ADT bundle) that can be downloaded from https://developer.android.com/sdk/index.html
  • If the environment is set up on a MAC system, the ADT should be installed in the Applications folder.
  • If the ADT is installed in any other location on MAC, or if the environment is set up on a Windows system, the ADT SDK path needs to be updated in local.properties file that is available in src\android folder in the extracted the source archive mobileworkspace-src.zip . In this file, point the sdk.dir variable to ADT SDK location on your desktop.
The adobe-lc-mobileworkspace-src.zip contains PhoneGap SDK 5.0. Ensure that PhoneGap SDK is not pre-installed.