Show Menu
TOPICS×

Requirements for the Experience Cloud Identity Service

Review this section to make sure you're using the right solutions, services, and code versions required by the Experience Cloud Identity Service.

Requirements Ensure Implementation Success and Support

A successful, supported implementation meets (or exceeds) the code requirements and follows the instructions as they appear in the Adobe help. An unsupported implementation will yield unexpected results and prevent Customer Care and our engineering teams from assisting with efforts to troubleshoot or resolve your issues with the ID service.
Implementation Type
Description
For a standard implementation with Dynamic Tag Management (DTM), you must:
  • Place the embed head code in the
    <head>
    section of your page.
  • Place the embed footer code before the closing
    </body>
    tag.
A standard implementation is not supported when you:
  • Place either of these DTM embed codes elsewhere in your markup and/or page code.
  • Append, add, or load DTM code with asynchronous methods, calls/callback methods, or wrappers.
  • Include multiple instances of embed code on the same page.
For non-standard, or manual implementations, you must set up the ID service as described by the procedures this guide. As with the DTM guidelines above, improper code placement and loading will create an unsupported implementation.

Experience Cloud Requirements: Organization ID

To use the ID service, your company must be enabled for the Experience Cloud and have an Organization ID. Check the following list if you're unsure of your company's Experience Cloud status and need to find your Organization ID.
The Organization ID is case sensitive and must be used exactly as provided.
Experience Cloud Status
Description
Enabled
If your company is enabled for the
Experience Cloud
but you do not have your Organization ID, see Organizational IDs (scroll down to the section
Find your Organization ID
).
Not sure
If you don't know your company's
Experience Cloud
status, ask whoever manages your Adobe account if members of your company can log in at marketing.adobe.com using an Adobe ID. If you can, then you're enabled and an administrator can view your Organization ID. To find the Organization ID, see the "Administration Page" section in Experience Cloud Administration .
Not enabled
If your company is not enabled for Experience Cloud, see Core Services - Enabling Your Solutions to get started.

Analytics Requirements: Regional Data Collection (RDC)

All tracking servers have been converted to RDC, so there is no need to change the Analytics tracking server. More info...

Code Libraries and Version Requirements

The following sections list the minimum code versions that are required to use the Experience Cloud ID service.
We recommend that you use the latest code versions rather than the required minimums.
JavaScript
Experience Cloud Solution
Code Library
Version Requirements
Experience Cloud
ID service
VisitorAPI.js
2.0 or higher
Analytics
AppMeasurement.js
1.6.4 or higher.
s_code.js
H.27
Note:
Analytics
s_code version H.27 is no longer supported with the release of the ID service version 1.6.0. Upgrade your code to the latest version of AppMeasurement.
2.0
Audience Manager
dil.js
5.0
Target
mbox.js
61
0.9.1

SDK Requirements for Android and iOS

At a minimum, the ID service requires the SDK versions listed below.
  • Android: 4.11.0
  • iOS: 4.11.0
We recommend that you use the latest code versions rather than the required minimums.
Your SDK code must be enabled for the ID service. Enable and download the latest SDK code for each app from your Adobe Mobile Services account. See also: