Show Menu
TOPICS×

Installation

Java

To install the Java library, add this dependency to your project’s POM:
<dependency> 
   <groupId>com.livefyre</groupId> 
   <artifactId>livefyre</artifactId> 
   <version>2.0.3</version> 
</dependency>
The Java library has dependencies on the following modules:
<dependency> 
   <groupId>com.sun.jersey</groupId> 
   <artifactId>jersey-client</artifactId> 
   <version>[1.18.1,)</version> 
</dependency> 
<dependency> 
   <groupId>com.google.code.gson</groupId> 
   <artifactId>gson</artifactId> 
   <version>[2.3,)</version> 
</dependency> 
<dependency> 
   <groupId>com.google.guava</groupId> 
   <artifactId>guava</artifactId> 
   <version>[18.0,)</version> 
</dependency> 
<dependency> 
   <groupId>org.apache.commons</groupId> 
   <artifactId>commons-lang3</artifactId> 
   <version>[3.0.1,)</version> 
</dependency> 
<dependency> 
   <groupId>org.bitbucket.b_c</groupId> 
   <artifactId>jose4j</artifactId> 
   <version>[0.4.1,)</version> 
</dependency> 
For more information, read the Java docs or see the source on GitHub .

NodeJS

To install the NodeJS library, run this line:
$ npm install livefyre
The NodeJS library has dependencies on the following modules:
"restler":">=3.2.0", 
"validator":"=3.5.0", 
"jsonwebtoken": ">=5.0.0" 
For more information, read the NodeJs docs or see the source on GitHub .

PHP

To install the PHP library with Composer, add this to your composer.json:
"require": { 
   "livefyre/livefyre-php-utils": "2.0.4" 
}
Then install using:
composer.phar install 
If you do not use Composer, obtain the latest version of the library using:
git clone https://github.com/Livefyre/livefyre-php-utils 
To use the library, add the following to your PHP script:
require_once("/path/to/livefyre-php-utils/src/Livefyre.php"); 
The PHP library has dependencies on the following modules:
"ext-json": "*", 
"rmccue/requests": ">=1.0" 
"firebase/php-jwt": ">=2.0" 
For more information, read the PHP docs or see the source on GitHub .

Python

To install the Python library, run this line:
$ pip install livefyre
The Python library has dependencies on the following modules:
PyJWT >= 1.0.1  
requests >= 2.2.1  
python-dateutil >= 2.2  
enum34 == 1.0  
ordereddict == 1.1 if sys.version_info[:2] < 2.7 
For more information, read the Python docs or see the source on GitHub .

Ruby

To install the Ruby library, add this line to your application’s Gemfile:
gem 'livefyre' 
Or install it yourself:
$ gem install livefyre
The Ruby library has dependencies on the following modules:
"jwt", '~> 1.4', ">= 1.4.1"  
"rest-client", '~> 1.8', ">= 1.8.0"  
"addressable", '~> 2.3', ">= 2.3.6" 
For more information, read the Ruby docs or see the source on GitHub .