Show Menu
TOPICS×

Set up your development environment

If you want to set up Primetime DRM, copy the files from the DVD. These files include JAR files that include code, certificates, and third-party classes. In addition, you need to request a certificate from Adobe Systems, Incorporated. Adobe then issues you multiple credentials that you use to protect the integrity of your packaged content, licenses, and communication between client and server.
Adobe provides the Primetime DRM SDK on DVD:
  1. Copy the following files from [ #/SDK/] to your development system (on your Java classpath):
    • adobe-flashaccess-certs.jar - Includes Adobe root certificates
    • adobe-flashaccess-sdk.jar - Includes Primetime DRM Core SDK classes
    • adobe-flashaccess-sdk-pro.jar - Includes Primetime DRM Professional SDK classes, required only for Professional features
  2. Copy the following files from [ #/SDK/thirdparty] to your development system:
    • bcmail-jdk15-141.jar
    • bcprov-jdk15-141.jar
    • commons-discovery-0.4.jar
    • commons-logging-1.1.1.jar
    • cryptoj.jar
    • jaxb-api.jar
    • jaxb-impl.jar
    • jaxb-libs.jar
    • relaxngDatatype.jar
    • rm-pdrl.jar
    • xsdlib.jar
    • jackson-annotations-2.4.0-rc4-20140522.175222-3.jar
    • jackson-core--2.4.0-rc4-20140529.184520-13.jar
    • jackson-databind-2.4.0-rc4-20140603.005043-38.jar
  3. (Optional) For improved performance, you can enable native support for cryptographic operations by copying the appropriate platform-specific library from [ #/SDK/thirdparty/cryptoj/] to your development system (remember to place the location on your path):
    • jsafe.dll - Windows
    • libjsafe.so - Linux
      32-bit and 64-bit versions of these libaries are available. You should only use the 64-bit version if you have a 64-bit OS and you run the 64-bit version of Java.
  4. (Optional) For functionality related to Adobe Flash Media Rights Management Server (FMRMS) 1.x compatibility, copy [DRM DVD]/SDK/adobe-flashaccess-lcrm.jar] to your development system:
    Deploy this only if you previously deployed FMRMS 1.x and do not want to re-package your FMRMS-protected content. In this case, you must add this support to your license server so it can manage old content and clients.