Show Menu
TEMAS×

AppMeasurement para JavaScript

Recopilación de notas de versiones de AppMeasurement para JavaScript.
Se puede descargar la última versión de todas las bibliotecas en Analytics > Administración > Administrador de códigos .

Versión 2.17.0

Fecha de lanzamiento: 23 de agosto de 2019
Función/Corrección
Descripción
Se ha agregado compatibilidad con Baidu
Se ha agregado compatibilidad con la reordenación de las cadenas de consulta Baidu.
Se corrigió un problema que hacía que se mostrara
Se ha corregido un problema que indicaba valores de visitantes antiguos en las visitas que se ponían en cola mientras se esperaba la inclusión.

Versión 2.16.0

Fecha de versión: 15 de agosto de 2019
Función
Descripción
sendBeacon admite vínculos de salida
Se ha implementado compatibilidad con sendBeacon en AppMeasurement para vínculos de salida. Esto mejorará el seguimiento de vínculos de salida y probablemente dará como resultado un incremento del tráfico. SendBeacon no se ejecuta en el contexto de una página sino en el contexto del explorador. Es decir, si una página se descarga con sendBeacon , la solicitud se completará. Esto resulta muy útil para los vínculos de salida porque hará que sea mucho más probable que la solicitud de vínculo de salida se complete.
Valores ECID/fid
Los valores ECID/fid ahora se almacenan en la caché en la primera visita, aunque cambie la configuración de OptIn.
DIL 9.3
Módulo de Gestión de público actualizado a DIL 9.3
Seguimiento de alcance de desplazamiento
Conmutador expuesto en s.ActivityMap.trackScrollReach para activar o desactivar el seguimiento de alcance de desplazamiento.
Servicio de ID de visitante 4.4.0
AppMeasurement actualizado para utilizar el servicio de ID de visitante 4.4.0.

Versión 2.15.0

Fecha de publicación: 15 de julio de 2019
  • Se ha agregado el seguimiento de alcance de desplazamiento de ActivityMap a la extensión Activity Map (AN -172949)
  • Se agregó DIL 9.2 a AppMeasurement (AN-182472)

Versión 2.14.0

Fecha de versión: 21 de mayo de 2019
  • Se han corregido los errores relacionados con la administración del estado de los parámetros del rastreador cuando hay varias visitas pendientes. (AN-176931, AN-176629, DTM-12758)
  • AppMeasurement actualizado para incluir Visitor.js 4.3.0 (AN-180049)

Versión 2.13.0

Fecha de versión: 10 de abril de 2019
Corrección de varios problemas detectados con clearVars. El problema se produce cuando las visitas se envían antes de que el rastreador esté listo. Cuando el rastreador está listo, la biblioteca puede establecer variables que ya se han borrado o cambiado. (AN-176931, AN-176629, DTM-12758).

Versión 2.12.0

Fecha de publicación: 22/02/2019
  • Módulo de Gestión de público actualizado a DIL 9.1 (AN-175255)
  • Política de seguridad GTM que no permite el módulo de Activity Map. (AN-174679)
  • Mejora de AppMeasurement para aceptar la exclusión cuando el servicio de Experience Cloud ID no se aprueba en el proceso de inclusión. (AN-175259)

Versión 2.11.0

Fecha de publicación: 11/02/2019
  • Se ha agregado compatibilidad con la nueva funcionalidad Servicios de inclusión de Adobe en AppMeasurement. (AN-163546)
  • Se ha agregado compatibilidad con el almacenamiento de datos de seguimiento de vínculos en el almacenamiento de sesión. (AN-162272)
  • Se ha agregado compatibilidad con el tipo de flujo de medios para Audio Analytics. (AN-173265)

Versión 2.10.0

Fecha de publicación: 20/09/2018
Esta versión garantiza el envío correcto de las cookies de la biblioteca de AppMeasurement para todos los tipos de conexión.
  • AppMeasurement bloquea las transmisiones de cookies durante POST. (AN-165538)
  • Se ha cancelado la compatibilidad con XDomainRequest. (AN-165733)
  • Se ha reducido la duración de las cookies predeterminadas de AppMeasurement de cinco a dos años. (AN-158572)
  • Eliminación del Módulo multimedia del Administrador de códigos (AppMeasurement) (AN-166590)

Versión 2.9.0

Fecha de versión: 24/05/2018
En el caso de los clientes que utilicen el servicio de Experience Cloud ID, se necesita la API de visitantes 3.0 o una versión posterior. Adobe recomienda actualizar a la última versión de la API de visitantes cada vez que se actualicen las bibliotecas de código asociadas (at.js, etc.).AppMeasurement.js
  • Se ha actualizado AppMeasurement para utilizar la interfaz de Visitante actualizada para solicitar los ID. (AN-151483)
  • Se ha solucionado un problema que causaba que la cookie de seguimiento seguía escribiéndose tras desactivar el seguimiento de enlaces. (AN-156332)
  • Se ha solucionado un problema que provocaba los desgloses registerPreTrackCallback y registerPostTrackCallback de firma de función callback cuando al llamarla varias veces. (AN-158566)

Versión 2.8.2

Fecha de versión: 12/04/2018
  • Se ha actualizado AppMeasurement para utilizar la interfaz de visitante actualizada para solicitar los ID. (AN-151483)
  • La cookie de seguimiento de enlace sigue escribiéndose tras desactivar el seguimiento de enlaces. (AN-156332)
  • Se ha reducido la duración de las cookies predeterminadas de AppMeasurement de cinco a dos años. (AN-158572)

Versión 2.8.1

Fecha de versión: 29/03/2018
Nuevo paquete de la API de Visitante 3.1.0 (AN-159524), que incluye las correcciones: (CORE-11390, CORE-10634)

Versión 2.8.0

Fecha de versión: 15/03/2018
Nuevo paquete de la API de Visitante 3.1.0 (AN-159524), que incluye las correcciones: (CORE-11390, CORE-10634)
  • Paquete VAPI 3.1 con AppMeasurement 2.8. (AN-158353)
  • Refactorización mediante la compilación del punto final de recopilación de datos para facilitar el uso compartido. (AN-156647)
  • Adición de métricas de temporización de viajes de ida y vuelta de solicitud a AppMeasurement. (AN-158343)

Versión 2.7.0

Fecha de versión: 18/01/2018
  • Abandono del soporte para las versiones 6 a 9 de Internet Explorer
  • Inclusión de la API de visitantes 3.0.0
  • Inclusión de DIL 7.00

Versión 2.6.0

Fecha de versión: 09/11/2017
Se ha solucionado un problema en el que la biblioteca de AppMeasurement no siempre configuraba la combinación de cuentas correcta cuando se llamaba a s_gl. (AN-152153)

Versión 2.5.0

Fecha de versión: 21/09/2017
  • Inclusión de dil.js 6.12 (módulo de Audience Manager)
  • Inclusión de la API de Visitante 2.5.0.

Versión 2.4.0

Fecha de versión: 17/08/2017
  • Se ha incluido dil.js v6.11
  • Se ha incluido la API 2.4.0 de visitante

Versión 2.3.0

Fecha de versión: 20/07/2017
  • Se ha solucionado un error por el que s.Util.getQueryParam capturaba #
  • Se ha añadido la versión 6.10 de dil.js (AN-145701)

Versión 2.2.0

Fecha de versión: 08/06/2017
  • Se ha añadido compatibilidad con varios órdenes de instanciación de AppMeasurement. (AN-138237)
  • Inclusión de la API de visitante 2.2.0. (AN-144042)

Versión 2.1.0

  • Se ha incluido la última versión de dil.js (AN-140396)
  • Se ha agregado compatibilidad para el parámetro adobe_mc_ref , que anula al referente de la página. (AN-131920)
  • Se ha vuelto a incluir la API 2.1.0 de visitante. (AN-140873)
  • Se ha agregado el parámetro mcorgid . (AN-139586)
  • Se ha agregado el parámetro (customerPerspective). (AN-140897)

Versión 2.0.0

Fecha de versión: 09/03/2017
  • Se ha movido a un nuevo proceso de creación que exige actualizar al número de versión 2.0.0. (AN-137878)
  • Se ha movido el tratamiento de mboxMCSDID a la ubicación de la sección correcta, donde se efectúa la llamada de seguimiento. (AN-138483)

Versión 1.8.0

Fecha de versión: 19/01/2017
  • Inclusión de la API de visitante 2.0.0
  • La función resecuenciada llama y comprueba de modo que SDID se consuma una vez completada la comprobación de anulación. (AN-134364)
  • Se han agregado los siguientes enlaces de llamadas antes y después del seguimiento. (AN-134567)
    • s.registerPreTrackCallback
    • s.registerPostTrackCallback Estas funciones toman como parámetros la rellamada (una función) y los parámetros que llevan a esa función. Por ejemplo:
    s.registerPreTrackCallback(function(requestUrl,a,b,c) { 
        console.log("pre track callback"); 
        console.dir(requestUrl); // Request URL 
        console.dir(a); // param1 
        console.dir(b); // param2 
        console.dir(c); // param3 
    }, "param1", "param2", "param3");
    
    
    La rellamada se invoca con requestUrl y cualquier parámetro que haya pasado cuando se registró la rellamada. Esto ocurre antes o después de la llamada de seguimiento, según el método que se utilice para registrar la rellamada. No se puede garantizar el orden en el que se realizan estas rellamadas. Las rellamadas que se registran en la función previa se invocan después de crearse la URL de seguimiento final. Las rellamadas posteriores se realizan cuando se ha llevado a cabo una llamada de seguimiento con éxito (si la llamada de seguimiento falla, no se llaman a estas funciones). Las rellamadas que se registren con registerPreTrackCallback no afectan a la llamada de seguimiento. Además, no se recomienda llamar a ninguno de los métodos de seguimiento en una rellamada registrada, ya que podría causar un bucle infinito.

Versión 1.7.0

Actualizado: 10/11/2016
  • Se ha incluido la API 1.10.1 de visitante.

Versión 1.7.0

Actualizado: 20/10/2016
  • Actualización del módulo de Audience Manager con la biblioteca de integración de Demdex (DIL) 6.6. (AN-132065)
  • Inclusión de la API de Visitante 1.9.0. (AN-132072)

Versión 1.7.0

Actualizado: 15/09/2016
  • Actualización del módulo Audience Manager de AppMeasurement con DIL 6.5 y configuraciones adicionales (AN-129411)
  • Inclusión de la API de visitantes 1.8.0 (AN-129887)

Versión 1.6.4

Actualizado: 18/08/2016
  • AppMeasurement actualizado que permite leer y escribir cookies AMCV. (AN-127098)
  • Inclusión de la API de Visitante 1.7.0.
También puede consultar las notas siguientes de la versión 1.6.3 de JavaScript, que incluyen requisitos actualizados para el servicio de Experience Cloud ID.

Versión 1.6.3

Actualizado: 04/08/2016
  • Se ha corregido un problema en el que AppMeasurement finalizaba de forma prematura las conexiones de solicitud. (AN-126448)
La versión 1.6.0 del servicio de Experience Cloud ID requiere AppMeasurement compatible con la versión 1.6.3 o superiores de JavaScript. Si desea actualizar el servicio de Experience Cloud ID a la versión 1.6.0, compruebe que está utilizando la versión de código AppMeasurement 1.6.3 o superior.

Versión 1.6.2

Fecha de versión: 21 de julio de 2016
  • Inclusión de la API de visitante 1.6.0.
  • Se ha corregido un problema que hacía que AppMeasurement llamara al método ofuscado incorrecto en la API de visitante. (AN-126006)
  • Se ha corregido un problema que daba lugar al error de JavaScript: “Attribute only valid on v:image”. (AN-124009)

Versión 1.6.1

Fecha de versión: 16 de junio de 2016
Inclusión de la API de Visitante 1.5.7.

Versión 1.6.1

Fecha de versión: 19 de mayo de 2016
JavaScript 1.5.6
  • Inclusión de la API de visitante 1.5.6
  • Se ha solucionado la administración del rastreo de clics de los vínculos en Firefox, que no activaba el evento completo.

Versión 1.6

Fecha de versión: 21 de abril de 2016
  • The AppMeasurement Activity Map module has been integrated in the AppMeasurement standard module, so that you only have to reference one .js file. Además, el seguimiento de Activity Map está habilitado de forma predeterminada. (AN-112689)
  • Se ha solucionado un problema de truncamiento que sucedía al enviar la orden de variables de cadena de consulta en AppMeasurement, por lo que pageURLRest se coloca al final. (AN-114647)

Versión 1.5.4

Fecha de versión: 17 de marzo de 2016
  • Inclusión de la API de Visitante 1.5.4
  • Compatibilidad con la anulación de la suscripción a la API de visitante 1.5.4+

Versión 1.5.3

Fecha de versión: 21 de enero de 2016
  • Se ha solucionado la administración del módulo Audience Manager cuando se usan POST para las llamadas de seguimiento. (AN-115381)
  • Se ha movido el resto de la URL de la página ("-g") al final de la cadena de solicitud de seguimiento. (AN-114647)

Versión 1.5.2

Fecha de versión: 5 de noviembre de 2015
  • Inclusión de la API de visitante 1.5.3.
  • Se ha solucionado la detección de IE11 para el truncado de la URL 2047 (AN-114914)

Versión 1.5.1

Fecha de versión: 17 de septiembre de 2015
  • Inclusión de la API de visitante 1.5.2

Versión 1.5.1

Fecha de versión: 29 de agosto de 2015
  • Inclusión de la API de visitante 1.5.1.

Versión 1.5.1

Fecha de versión: 16 de julio de 2015
  • Se ha actualizado el módulo Audience Manager para que utilice AAM DIL 6.2 y los ID getCustomer desde VisitorAPI.js y los traslade en AAM o realice la llamada de evento a AAM. (AN-104978)

Versión 1.5

Fecha de versión: 18 de junio de 2015
  • Compatibilidad con la API de visitante 1.5, que utiliza el método getCustomerIDs para recopilar ID de cliente y estados autenticados, y envía los ID con solicitudes de recopilación de datos.
  • Se ha corregido la creación de iframes de destino duplicados en el módulo AudienceManagement (DIL 6.1)
  • Se ha solucionado el error conocido descrito en la versión 1.4.5.

Versión 1.4.5

Fecha de versión: 21 de mayo de 2015
Función Descripción
Extensión de iOS
A partir del SDK 4.5 de iOS , una nueva extensión de iOS le permite recopilar el uso de los datos de sus aplicaciones de Apple Watch, utilidades de Today, utilidades de edición fotográfica y todas las demás aplicaciones de extensión de iOS .
Extensión de Android Wearable
A partir de la versión 4.5 del SDK para Android , una nueva extensión de Android le permitirá recopilar datos de su aplicación Android Wearable.
  • Inclusión de la API de visitante 1.4.
  • Se ha actualizado el módulo AudienceManagement para que utilice DIL versión 6.0.
Problema conocido
En las integraciones del módulo Visitor API / Audience Manager de AppMeasurement, habrá dos solicitudes de iFrame de publicación de destino realizadas en IE6-9: //fast.<subdomain>.demdex.net/dest5.html y //fast.<subdomain>.demdex.net/dest4.html . El comportamiento correcto, tal como se ha observado en otros exploradores, es cargar únicamente //fast.<subdomain>.demdex.net/dest5.html .

Versión 1.4.4

Fecha de versión: 16 de abril de 2015
Función Descripción
Datos personalizados con métricas del ciclo vital
Ahora puede incluir variables de datos de contexto personalizado con métricas del ciclo vital.
Compatibilidad con seguimiento de las señalizaciones web en PhoneGap
The trackBeacon and clearCurrentBeacon calls are now available in PhoneGap .
Una pequeña corrección para borrar el ID del perfil de la llamada del servidor ligero después de la llamada trackLight .

Versión 1.4.3

Fecha de versión: 19 de febrero de 2015
  • Se ha sistematizado todo el tratamiento de las llamadas de seguimiento demoradas con lo cual se han corregido los problemas con las variables de copia de seguridad durante la demora, por ejemplo, el objeto en el que se ha hecho clic.
  • Se ha cambiado la opción a no hacer seguimiento automático del referente tras la primera llamada de seguimiento, de modo que las llamadas segunda, tercera, etc. (por lo general seguimiento de vínculos) no contarán al referente doble si se ha configurado manualmente s.referrer se ha establecido manualmente antes de la primera llamada de seguimiento.
  • Se ha actualizado el zip de distribución para incluir la API de visitante 1.3.5.

Versión 1.4.2

Fecha de versión: 15 de enero de 2015
  • Se ha solucionado la administración del procesamiento previo de WebKit para impedir que se haga un seguimiento de las páginas procesadas previamente que no se muestran.
  • El zip de distribución se ha actualizado para incluir la API 1.3.4 de visitantes y un módulo AudienceManagement actualizado que incluye la versión 5.5 de DIL.

Versión 1.4.1

Fecha de versión: 18 de septiembre de 2014
  • Se agregó una variable tagContainerMarker que permite la implementación para especificar hasta 4 caracteres que se anexan a la cadena de versión junto con un delimitador de guion adicional. Se usa mediante la administración dinámica de etiquetas.
    // JavaScript 
    s.tagContainerMarker = "D1.0"; 
    
    // Data Collection request 
    //.../b/ss/myrsid/1/JS-1.4.1-D1.0/s43317392037311?...
    
    
    Los cuatro caracteres se limitan a caracteres permitidos en las rutas de archivo de URL, como caracteres alfanuméricos y punto.
  • En las páginas con doble etiqueta con código H, se corrigió un bucle que se podía producir durante el seguimiento automático de vínculos (descarga y salida) cuando se habilita el seguimiento forzado de vínculos (exploradores de Webkit predeterminados). Además, se agregó una protección general en torno al seguimiento automático de vínculos para impedir bucles similares. Esta protección limita el seguimiento automático de vínculos de clics repetidos con el mismo objeto a una vez cada 10 segundos. Esta protección se aplica solo al seguimiento automático de vínculos, de modo que las llamadas al seguimiento manual de vínculos (s.tl) no están limitadas. Los clics a diferentes objetos tampoco se ven afectados por esta protección y se seguirán.
  • Se corrigió el control del objeto en el que se hace clic cuando es necesario un retraso.
  • Se corrigió un problema que provocaba un recuento doble de vista de página cuando se llamaba a s.t desde una función de onclick de vínculo, si la API del visitante no tiene aún los valores necesarios.
  • Compatibilidad con HTTP POST.
    For an Analytics call to use the POST method instead of the GET method in AppMeasurement (a method of solving truncated URLs in IE ), you must be using the latest Visitor ID Service implementation for Experience Cloud.

Versión 1.4

Fecha de versión: 21 de agosto de 2014
  • Se ha eliminado el seguimiento de los plugins del explorador (parámetro de consulta p ) porque los plugins ya no se incluyen en los informes en la versión 15.
  • Adición del módulo AudienceManagement en el zip de descarga.
Se ha agregado compatibilidad con eVars (76 - 250) y eventos (101-1000) adicionales.
El código H no admite los eventos y eVars adicionales.
JavaScript

Versión 1.3.2

Fecha de versión: 19 de junio de 2014
  • Tratamiento fijado de marcas listas y de espera para campos de API de visitante como el ID de visitante de Analytics heredado que estaba causando errores.
  • Compatibilidad para nuevas funciones en el servicio de ID de visitante 1.3.

Versión 1.3.1

Fecha de versión: 22 de mayo de 2014
  • La función AppMeasurement para s_gi de JavaScript no estaba encontrando correctamente instancias creadas con el código H s_gi . Tenga en cuenta que este problema impactó únicamente en algunas implementaciones duales donde AppMeasurement para JavaScript y código H estaban en la misma página con instancias separadas y el grupo de informes estaba usando s_gi para encontrar instancias.

Versión 1.3

Fecha de versión: 17 de abril de 2014

Versión 1.2.4

Fecha de versión: 13 de marzo de 2014
  • Correcciones de errores para vídeo de Heartbeat.

Versión 1.2.3

Fecha de versión: 20 de febrero de 2014
  • Correcciones de errores para vídeo de Heartbeat.

Versión 1.2.2

Fecha de versión: 6 de febrero de 2014
  • Se ha solucionado un error de compatibilidad con el módulo DIL de Audience Manager. Audience ManagerLos clientes de también deben actualizar a la versión 4.8 del módulo DIL.

Versión 1.2.1

Fecha de versión: 15 de noviembre de 2013

Versión 1.2

Fecha de versión: 14 de noviembre de 2013

Versión 1.1.1

  • Se ha impedido que se enviara una llamada de seguimiento de vínculos desde los exploradores Opera en vínculos que empiezan con "opera:" ("opera:" se parece a "about:" y "chrome:" en otros exploradores).
  • Se ha agregado alt="" en todos los objetos de imagen para cumplir con la Accessible Video and Communications Act (ley estadounidense de accesibilidad para comunicaciones y vídeo).

Versión 1.1

Fecha de versión: 18 de septiembre de 2013
  • Se ha corregido la posibilidad de colocar el código de página y la biblioteca en la etiqueta head .
  • Se ha agregado la compatibilidad con el módulo onLoad que faltaba.

Versión 1.0.3

Fecha de versión: 15 de agosto de 2013
  • Se ha añadido la compatibilidad para la implementación a través del administración de etiquetas de Adobe.
  • Se ha solucionado el problema que evitaba que las variables de jerarquía se fijaran en el objeto AppMeasurement.

Versión 1.0.2

Fecha de versión: 18 de julio de 2013
  • Ahora el seguimiento automático de vínculos ignora el hash/fragmento. Anteriormente, se seguía automáticamente la siguiente URL porque la href entera terminaba en .pdf :
    <a href="index.htm#anchor.pdf">Test Link</a>
    
    
    Ahora se ignora el hash/fragmento de modo que el vínculo solo se sigue cuando el nombre del archivo termina en una extensión que coincide.

Versión 1.0.1

Fecha de versión: 23 de mayo de 2013
Ya tiene disponible en el Administrador de códigos una nueva biblioteca AppMeasurement para JavaScript. Esta biblioteca proporciona la misma funcionalidad básica de s_code.js, pero es más rápida y más ligera tanto en sitos móviles como del escritorio.
  • De 3 a 7 veces más rápido que el código H.25
  • Solo 21 k sin comprimir y 8 k comprimidos con gzip (el código H.25 tiene 33 k sin comprimir y 13 k comprimidos con gzip).
  • Compatibilidad nativa para obtener parámetros de consulta, leer y escribir cookies y realizar un seguimiento de vínculos avanzado.
  • Pequeño y lo suficientemente rápido para su uso en sitios móviles, así como lo bastante sólido para su uso en el escritorio web completo, lo que le permitirá aprovechar una sola biblioteca en todos los entornos web.
Consulte AppMeasurement para Javascript en la Guía de implementación de Analytics
Algunos complementos no son compatibles con esta nueva versión. Consulte la Compatibilidad de complementos para obtener más información.