Show Menu
TEMAS×

Funciones obsoletas y eliminadas

Adobe evalúa constantemente las funciones de sus productos para identificar aquellas que sean antiguas y que deban reemplazarse con alternativas más modernas para mejorar la experiencia de los clientes, intentando garantizar en todo momento la compatibilidad con versiones anteriores. Como Adobe Campaign Classic funciona con herramientas de terceros, la compatibilidad se actualiza de forma regular para implementar únicamente versiones compatibles. Las versiones que ya no son compatibles con Adobe Campaign Classic se enumeran a continuación y en la Matriz de compatibilidad .
Para comunicar la inminente eliminación/sustitución de las funciones de Campaign Classic, se aplican las siguientes reglas:
  • Primero, se anuncia que la función quedará obsoleta. Aunque las funciones obsoletas todavía pueden estar disponibles y ser compatibles para los usuarios existentes, no se van a mejorar ni documentar.
  • La eliminación completa de la función se producirá en la siguiente versión como muy pronto. En esta página se anuncia la fecha objetivo real de la eliminación.
Este proceso proporciona a los clientes al menos un ciclo de versiones para actualizar su implementación a una nueva versión o a la versión sucesora de la función obsoleta antes de su eliminación real.
Las versiones de Adobe Campaign y las nuevas funciones se enumeran en las Notas de la versión .

Funciones obsoletas

Esta sección enumera las funciones y capacidades que se han marcado como obsoletas en las últimas versiones de Campaign Classic.
Por lo general, las funciones que se planea eliminar en una versión posterior se definen en primer lugar como obsoletas. Estas funciones y funcionalidades ya no están disponibles para los nuevos clientes de Campaign Classic, o no deben usarse para ninguna implementación nueva. También se eliminan de la documentación del producto.
Se aconseja a los clientes que comprueben si utilizan la función o la funcionalidad en su implementación actual y que cambien su implementación. Consulte la fecha de eliminación objetivo para planificar el entorno y las actualizaciones del proyecto según corresponda.
Función Sustitución
Conectores SMS
A partir de la versión Campaign 20.2, los siguientes conectores SMS quedan obsoletos.
  • NetSize
  • SMPP genérico (SMPP versión 3.4 compatible con modo binario)
  • Sybase365 (SAP SMS 365)
  • Comunicaciones de CLX
  • Tele2
  • O2
  • iOS
Si utiliza uno de estos conectores, debe adaptar la implementación en consecuencia. Más información
Descubra cómo migrar los conectores heredados en esta nota técnica .
Fecha de eliminación objetivo: 2021
canal de fax
A partir de la versión Campaign 20.2, el canal de fax queda obsoleto.
Si utiliza este canal, debe adaptar la implementación en consecuencia. Obtenga más información sobre los canales de Campaign.
Fecha de eliminación objetivo: 2021

Funciones eliminadas

Esta sección enumera las funciones y capacidades que se han eliminado de Campaign Classic.
Área: función Sustitución
Archivado de correos electrónicos basado en archivos
A partir de la versión 20.2 de Campaign, el archivado de correos electrónicos basado en archivos ya no está disponible. El archivado de correo electrónico ya está disponible a través de una dirección de correo electrónico específica de CCO. Más información
Administración de posibles clientes
A partir de la versión 20.2 de Campaign, el paquete de Administración de posibles clientes ya no está disponible. Se puede implementar una funcionalidad similar mediante otras actividades nativas del flujo de trabajo y modificaciones del modelo de datos.
Documentación de las API Campaign: archivo jsapi.chm A partir de la versión 19.1 de Campaign, las API de Campaign Classic están disponibles en una página dedicada. Si utilizó el archivo jsapi.chm heredado, debería consultar la nueva versión en línea .
Organización de campañas - Marketing predictivo A partir de la versión 18.10 de Campaign, las funcionalidades de marketing predictivas ya no están disponibles.
Aplicaciones web: micrositios A partir de la versión 18.10 de Campaign, los micrositios ya no están disponibles. Puede mejorar la seguridad restringiendo el acceso solo a dominios dedicados en archivos de configuración de Adobe Campaign, y utilizar direcciones URL personalizadas en Campaign mediante alias DNS. Más información
Notificaciones push: conector binario de iOS Por recomendación de Apple, Adobe ha eliminado el conector binario heredado de iOS a partir de la versión 18.10 de Campaign. Ya está disponible el conector basado en HTTP/2 más funcional y eficiente.
API decryptString
A partir de la versión 18.6 de Campaign y por motivos de seguridad, la API decryptString  ya no está disponible de forma predeterminada en las nuevas instalaciones.
En el contexto de una actualización posterior a la versión 18.6 (y versiones posteriores), esta API ya no se activa y se ha sustituido por la función decryptPassword. Más información
Canal móvil: mensajes push de MMS y WAP A partir de la versión 18.4 de Campaign, los canales push MMS y Wap ya no están disponibles. Como reemplazo, puede aprovechar los envíos por SMS y Push .
Canal móvil: LINE v1 A partir de la versión 18.4 de Campaign, el paquete LINE Connect ya no está disponible. Adobe recomienda utilizar el nuevo paquete LINE Channel como reemplazo. Más información

Compatibilidad obsoleta

Los siguientes sistemas son obsoletos para Campaign Classic. Consulte la Matriz de compatibilidades para actualizar a una versión más reciente o pasar a un sistema nuevo antes de que finalice el periodo de compatibilidad.

Versión de Adobe Campaign 20.2

A partir de la versión 20.2, los siguientes sistemas quedan obsoletos para Campaign Classic. La compatibilidad finaliza en la versión 20.3: octubre de 2020.
  • Consola de cliente: Windows 7
  • Conectores de SMS heredados: consulte Funciones obsoletas
  • DB2 UDB 10.5 para el acceso de datos federado (FDA)

Versión de Adobe Campaign 19.2

A partir de la versión 19.2, los siguientes sistemas operativos quedan obsoletos para Campaign Classic. La compatibilidad finalizará a finales del año 2020.
  • Servidor web: Apache 2.2.
  • Sistema operativo: CentOS 6.
Consulte la Matriz de compatibilidades para actualizar a una versión más reciente o pasar a un sistema nuevo.

Fin de compatibilidad

Adobe Campaign Classic es compatible con todos los sistemas y herramientas enumerados en la Matriz de compatibilidad . Cuando las versiones específicas de estos sistemas y herramientas de terceros llegan al final de su vida útil (EOL) con sus respectivos creadores, Adobe Campaign ya no es compatible con ellas: se anuncian como funciones obsoletas y, después, se eliminan de nuestra matriz de compatibilidad en la versión posterior del producto. Para evitar problemas, compruebe que se encuentra en una versión compatible de cualquier sistema enumerado en la matriz de compatibilidad.

Consola de cliente

La consola del cliente de Adobe Campaign Classic ya no se puede ejecutar en los siguientes sistemas, ya que su editor los ha desaprobado. Los clientes que ejecuten la consola de cliente de Campaign en una de estas versiones deben actualizar a la versión más reciente antes de la fecha de eliminación objetivo. Consulte la matriz de compatibilidades .
  • Windows Server 2003, 2008, 2008 R2
  • Windows XP, Vista
A partir de la versión 20.1 de Campaign, la consola de cliente de 32 bits de Campaign Classic ya no es compatible con las versiones más recientes de Campaign. Debe utilizar la consola de cliente de 64 bits.

Sistemas operativos

A partir de la versión 19.1, Adobe Campaign deja de ser compatible con los siguientes sistemas operativos.

Servidores web

A partir de la versión de primavera (19.1), Adobe Campaign deja de ser compatible con el siguiente servidor web.

Herramientas

A partir de la versión de primavera (19.1), Adobe Campaign deja de ser compatible con las siguientes herramientas.

Motores de bases de datos

Adobe no admite los siguientes motores de bases de datos, ya que su editor los ha desaprobado. Los clientes que ejecutan estas versiones deben actualizar a la versión más reciente o pasar a otra.
Consulte la Matriz de compatibilidades de Campaign para acceder a la lista de versiones compatibles.
Acceso de datos federado (FDA)
A partir de la versión de primavera (19.1), Adobe Campaign deja de ser compatible con los siguientes servidores FDA.
Campaign Classic no es compatible con los siguientes servidores de acceso de datos federado (FDA).
  • DB2 UDB 9.5, 9.7. La versión más reciente de DB2 es compatible mediante el acceso de datos federado (FDA). Más información
  • Oracle 9i, 10G R2. Las versiones más recientes de Oracle son compatibles mediante el acceso de datos federado (FDA). Más información
  • PostgreSQL 8.3, 8.4, 9.0, 9.1, 9.2. Las versiones más recientes de PostgreSQL son compatibles con el acceso de datos federados (FDA). Más información
  • MSSQL 2000, 2005, 2008 R2. Las versiones más recientes de SQL Server son compatibles mediante el acceso de datos federado (FDA). Más información
  • MySQL 5.1. Las versiones más recientes de MySQL son compatibles mediante acceso de datos federado (FDA). Más información
  • InfiniDB llegó al fin de su vida útil. Más información
  • Teradata 13, 13.1. Las versiones más recientes de Teradata son compatibles mediante el acceso de datos federado (FDA). Más información
  • Netezza 6.02, 7.0. Netezza llegó al final de su vida. Más información
  • AsterData 5.0. AsterData llegó al final de su vida. Más información
  • Sybase IQ 15.2, 15.4, 15.5 y Sybase ASE 15.0. Las versiones más recientes de Sybase son compatibles con Acceso de datos federado (FDA). Más información
  • Hadoop a través de HiveSQL: Hadoop 2.7.3, HiveSQL 1.2.1. Adobe Campaign Classic seguirá siendo compatible con las versiones de Hadoop incluidas en la lista a través de HiveSQL a través del Acceso de datos federado (FDA), pero estas versiones se combinan con: HortonWorks (HDP 2.4.X, 2.5.x, 2.6.x) y HDInsight 3.4 (HDP 2.4), 3.5 (HDP 2.5), 3.6 (HDP 2.6)
Servidor RDBMS
Adobe Campaign no es compatible con los siguientes servidores RDBMS:
  • Oracle 10GR2
  • PostgreSQL 9.0 a 9.3
  • SQL Server 2005
  • MySQL 5.1
  • DB2 UDB 9.7