Show Menu
TEMAS×

Creación de una tabla

Puede añadir una tabla a un informe para visualizar los datos. Puede ser una tabla dinámica creada en función de las medidas del cubo, una lista con un grupo o una tabla que contenga un desglose de valores.

Creación de una lista con grupo

Una tabla de tipo List with group permite agrupar datos en la tabla y generar estadísticas sobre ella. Por ejemplo, puede crear totales y subtotales de los datos. Cada grupo tiene su propio encabezado, detalle y pie de página.
La actividad Page que contiene la tabla debe ir precedida por una actividad Query o Script para recopilar los datos que desee analizar en el informe. Para obtener más información sobre estas actividades, consulte Recopilación de datos para analizar y Actividad de secuencia de comandos .

Principio de funcionamiento

Puede que necesite analizar varias categorías de datos a la vez. Una lista con grupo permite combinar datos y crear estadísticas sobre varios grupos de datos dentro de la misma tabla. Para ello, puede crear un grupo en la tabla.
En el siguiente ejemplo, el grupo muestra todas las campañas de la base de datos, las entregas y el número de mensajes enviados por entrega y por campaña.
It lets you list the campaigns ( Label (Campaign) , the list of deliveries ( Label ) linked to the campaign, and lets you count the number of messages sent per delivery ( Processed) , before adding them up for each campaign ( Sum(@processed) ).

Pasos de implementación

Aquí se proporciona un ejemplo completo de implementación: Caso de uso: Cree un informe con una lista de grupos .
Tenga en cuenta los siguientes pasos para crear una tabla de tipo “Lista con grupo”:
  1. Vaya al gráfico del informe y coloque una actividad Query . Consulte Recopilación de datos para analizar .
  2. Rellene la tabla de origen y seleccione los campos de la tabla que corresponden a las estadísticas.
  3. Coloque una actividad Page en el gráfico. Para obtener más información, consulte Elementos estáticos .
  4. Insert a List with group type table into the page.
  5. Especifique la ruta de datos o la tabla seleccionada como fuente de datos en la consulta.
    Este paso es obligatorio si desea recuperar los campos de la tabla de origen posteriormente e insertarlos en las celdas de la tabla.
  6. Creación de una tabla y su contenido.
  7. Visualice el informe terminado en la pestaña Preview . Luego puede publicar el informe y exportarlo a un formato diferente en caso necesario. Para obtener más información, consulte Exportación de un informe .

Adición de líneas y columnas

De forma predeterminada, una tabla de texto List with group incluye un encabezado, una línea de detalle y una línea de pie de página.
El propio grupo incluye líneas de encabezado, detalle y pie de página.
  • Línea de encabezado : esta línea permite asignar un título a las columnas de la tabla.
  • Línea de detalle : esta línea contiene los valores estadísticos.
  • Línea de pie de página : esta línea permite mostrar los valores totales.
Puede añadir líneas y columnas según sus necesidades.
El grupo se puede colocar en cualquier línea de la tabla e incluir su propio encabezado, detalle y líneas de pie de página.
Línea y columna : para añadir o eliminar una línea o una columna, vaya a una línea o columna existente y utilice el menú contextual.
El tipo de línea que añada depende de la ubicación del cursor. For example, to add a header line, place your cursors on a header, then click Add > A line above/below .
El ancho de las columnas se puede modificar mediante el elemento Column format .
Grupo : para añadir un grupo, vaya a una línea y seleccione el elemento correspondiente del menú desplegable.

Definición del contenido de la celda

Para editar una celda de la tabla y definir su contenido y formato, vaya a la celda y utilice el menú contextual.
Utilice la entrada de menú Expression para seleccionar los valores que se van a mostrar.
  • Para insertar los valores que se van a analizar directamente en la tabla, selecciónelos entre los campos disponibles.
    La lista de campos disponibles coincide con el contenido de la consulta antes de la tabla en el gráfico de creación de informes.
  • Introduzca una etiqueta para una celda, por ejemplo, de encabezado.
    Para ello, utilice el mismo proceso que para insertar un campo en la base de datos, pero no seleccione una expresión. Introduzca la etiqueta en el campo Label . Se muestra tal cual.
  • Cálculo de un acumulado (un promedio, una suma, etc.) para mostrarlo en la celda.
    Para ello, utilice la entrada de menú Aggregates y seleccione la campaña deseada.

Definición del formato de la celda

To define the cell format, the Cell format... menu lets you access all formatting options available for the selected cell.
Estas opciones permiten personalizar la renderización final del informe y facilitar la lectura de la información.
Utilice el campo Carriage return para exportar datos a Excel: seleccione el valor Yes para forzar el retorno de carro. Este valor se mantiene al exportar. Para obtener más información, consulte Exportación de un informe .
The Cell format window lets you access the following tab:
  • La Value ficha
  • La Borders ficha
  • La Click ficha
  • La Extra ficha
La pestaña Value permite cambiar la fuente y los distintos atributos de valor o definir un formato en función de su naturaleza.
The format changes data display: for example, the Number , Monetary and Percentage formats allow you to align the figures on the right and display decimal points.
Ejemplo de cómo configurar un formato de divisas: puede especificar la moneda en la que se expresan los valores, elegir si se separan o no los millares y mostrar los valores negativos en rojo. La posición del símbolo de divisa depende del idioma del operador definido en su perfil.
Ejemplo de configuración para fechas: puede elegir si desea mostrar o no la hora.
La pestaña Bordes le permite añadir bordes a las líneas y columnas de la tabla. La adición de bordes a las celdas puede dar lugar a problemas de rendimiento al exportar informes de gran tamaño a Excel.
If necessary, you can define borders in the table template ( Administration > Configuration > Form rendering ).
En este caso, se encuentra con la siguiente sintaxis:
En la pestaña web:
 .tabular td {
 border: solid 1px #000000;
 }

En la pestaña Excel:
 <style name="odd" fillColor="#fdfdfd">
  <border>
   <borderTop value="solid 0.05pt #000000" />
   <borderBottom value="solid 0.05pt #000000" />
   <borderLeft value="solid 0.05pt #000000" />
   <borderRight value="solid 0.05pt #000000" />
  </border>
 </style> 
 
 <style name="even" fillColor="#f7f8fa">
  <border>
   <borderTop value="solid 0.05pt #000000" />
   <borderBottom value="solid 0.05pt #000000" />
   <borderLeft value="solid 0.05pt #000000" />
   <borderRight value="solid 0.05pt #000000" />
  </border>
 </style> 

La pestaña Click permite definir una acción cuando el usuario hace clic en el contenido de una celda o de la tabla.
En el ejemplo que se muestra a continuación, al hacer clic en el valor de la celda se muestra la segunda página del informe, que contiene información sobre la entrega en la celda.
La pestaña Extra le permite vincular un campo visual a los datos, como una marca de color o una barra de valor. La marca de color se utiliza cuando la tabla se muestra como una leyenda en un gráfico. Para obtener más información, consulte el ejemplo de implementación: Paso 5: Crear la segunda página .

Caso de uso: Creación de un informe con una lista de grupos

En este ejemplo creamos un informe de dos páginas: la primera página contiene la lista y el total de entregas por campaña, así como el número de mensajes enviados. Los nombres de entrega son vínculos en los que puede hacer clic y le permiten ir a la segunda página del informe para ver el desglose de entregas por dominio de correo electrónico, según la entrega seleccionada, con una tabla y un gráfico. En la segunda página, la tabla sirve como una leyenda para el gráfico.

Paso 1: Creación de un informe

Cree un nuevo informe que corresponda al esquema de campañas, Campaigns (nms) .
Haga clic en Save para crear el informe.
Vaya al gráfico y añada los primeros componentes que va a utilizar para diseñar el contenido del informe: una primera consulta y una primera página.

Paso 2: Creación de la primera consulta

La primera consulta le permite recopilar las entregas vinculadas a cada campaña. El objetivo es mostrar un informe sobre las distintas entregas de la base de datos de Adobe Campaign enlazados a cada campaña.
Haga doble clic en la primera consulta para editarla y luego siga los pasos descritos a continuación para configurarla:
  1. Start by changing the schema on which the query's source is applied: select the Deliveries (nms) schema.
  2. Click the Edit query link and display the advanced fields.
  3. Seleccione los campos siguientes:
    • la etiqueta de entrega,
    • la clave principal de la entrega,
    • la etiqueta de campaña,
    • el indicador de entregas procesados,
    • la clave externa del vínculo de la campaña,
    • el indicador de tasa de error.
    Se recomienda enlazar un alias a cada campo para facilitar la selección de datos de la tabla que se añade a la primera página del informe.
    Para este ejemplo, se utilizan los siguientes alias:
    • Etiqueta: @label
    • Clave principal: @deliveryId
    • Etiqueta (campaña): @label1
    • Procesado: @processed
    • Clave externa del vínculo “Campaña” (campo “id”): @operationId
    • Tasa de error: @errorRatio
  4. Click the Next button twice to get to the Data filtering step.
    Añada una condición de filtro para recopilar solamente las entregas vinculadas a una campaña.
    La sintaxis de este filtro es la siguiente: “Foreign key of the 'Campaigns' link greater than 0”.
  5. Haga clic en Finish para guardar estas condiciones y haga clic en Ok para cerrar el editor de consultas.

Paso 3: Creación de la primera página

En este paso, configuramos la primera página del informe. Para ello, siga los siguientes pasos:
  1. Abra la actividad Page e introduzca su título, por ejemplo Deliveries , en este caso.
  2. Inserte una lista con un grupo mediante la barra de herramientas e introduzca su etiqueta, por ejemplo: List of deliveries per campaign.
  3. Click the Table data XPath... link and select the delivery link, i.e. [query/delivery] .
  4. Haga clic en la pestaña Data y cambie el diseño de la tabla: añada tres columnas a la derecha.
  5. Añada un grupo.
    Este grupo le permite agrupar las campañas y las entregas vinculadas a ellas.
  6. En la ventana del grupo, haga referencia a la clave externa del vínculo “Campaña” y cierre la ventana.
  7. Edite la primera celda del encabezado del grupo e inserte el campo Label de las campañas como una expresión.
  8. Edite la segunda celda de la línea de detalles y seleccione las entregas Label .
  9. Edite el formato de esta celda y abra la pestaña Click . Configure las opciones adecuadas para que cuando los usuarios hagan clic en el nombre de una entrega, se abra en la misma ventana.
    To do this, select a Next page type action and select In the same window as an open option.
  10. In the lower section of the window, click Add and specify the /vars/selectedDelivery path and the @deliveryId expression that matches the alias of the primary key of the delivery, as defined in the query created previously. Esta fórmula permite acceder a la entrega seleccionada.
  11. Edite la segunda celda de la línea de pie de página del grupo e introduzca Total per campaign como etiqueta.
  12. Edit the third cell of the header line of the group and enter Number of messages sent as a label.
    Esta información coincide con el título de la columna.
  13. Edite la tercera celda de la línea de detalle y seleccione el indicador de mensaje procesado como expresión.
  14. Edite la tercera celda de la línea de pie de página del grupo, seleccione el indicador de entrega procesado y aplique el acumulado Sum al mismo.
  15. Edite la cuarta celda de la línea de detalle y seleccione la tasa de error de entrega como expresión.
  16. Seleccione esta celda para visualizar una barra de valores que represente la tasa de errores de entrega.
    Para hacerlo, acceda al formato de celda y vaya a la pestaña More . Select the Value bar entry in the drop-down list and select the Hide the cell value option.
    Ahora puede ver una renderización del informe. Haga clic en la pestaña Preview y seleccione la opción Global : esto muestra la lista de todas las entregas de la base de datos de Adobe Campaign que están relacionados con una campaña.
    Se recomienda utilizar la pestaña Preview para asegurarse de que los datos de la tabla estén seleccionados y configurados correctamente. Una vez realizada esta acción, puede ir al formato de la tabla.
  17. Aplique el estilo Bold a las celdas que muestran el total por campaña y el número total de mensajes procesados.
  18. Haga clic en la primera celda de la línea de encabezado del grupo, la que muestra el nombre de la campaña, y seleccione Edit > Merge to right .
    Al combinar las dos primeras celdas de la línea del encabezado del grupo, se realinean el título de la campaña y la lista de entregas vinculada.
    Se recomienda esperar hasta que el informe se haya creado antes de combinar las celdas, ya que la combinación es irreversible.

Paso 4: Creación de la segunda consulta

Queremos añadir una segunda consulta y una segunda página para mostrar el detalle de una entrega cuando el usuario haga clic en el informe. Antes de añadir la consulta, edite la página que ha creado y habilite la transición saliente para que se pueda enlazar a la consulta.
  1. Add a new query after the Page activity and edit its schema: select the Recipient delivery logs schema.
  2. Edite la consulta y defina las columnas de salida. Para mostrar el número de entregas por dominio de correo electrónico, debe hacer lo siguiente:
    • calcular la suma de las claves principales para contar el número de “logs” de entrega:
    • recopilar dominios de correo electrónico del destinatario agrupar información en este campo: para hacerlo, seleccione la opción Group en la columna de nombre de dominio.
    vínculo los siguientes alias a los campos:
    • count(primary key): @count
    • Email domain (Recipient): @domain
  3. Click the Next button twice: this takes you to the Data filtering step.
    Añada una condición de filtrado para recopilar únicamente la información vinculada a la entrega seleccionada.
    La sintaxis es la siguiente: Foreign key of the 'Delivery' link equals the value of the setting $([vars/selectedDelivery])
  4. Cierre la ventana de configuración de consulta y añada una página al gráfico justo después de la segunda consulta.

Paso 5: Creación de la segunda página

  1. Edite la página e introduzca su etiqueta: Email domains .
  2. Desmarque la opción Enable output transitions : esta es la última página del informe y no va seguida de otra actividad.
  3. Añada una nueva lista con un grupo mediante el menú contextual y denomínela Dominios de correo electrónico por destinatario .
  4. Click the Table data XPath... and select the Recipient delivery logs link.
  5. En la pestaña Data , adapte la tabla de la siguiente manera:
    • Añada dos columnas a la derecha.
    • En la primera celda de la línea de detalle, añada la expresión rowNum()-1 para contar el número de líneas. Then alter the format of the cell: in the Extra tab, select Color tab and click Ok .
      Esta configuración le permite utilizar la tabla como pie de ilustración para el gráfico.
    • In the second cell of the detail line, add the Email domain(Recipient) expression.
    • In the third cell of the detail line, add the count(primary key) expression.
  6. Añada un gráfico circular a la página mediante el menú contextual y asígnele la etiqueta dominios de correo electrónico. Para obtener más información, consulte Tipos de gráficos y variantes .
  7. Click the Variants link and deselect the Display label and the Display caption options.
  8. Compruebe que no esté configurada ninguna ordenación de valores. Para obtener más información, consulte esta sección .
  9. In the Data tab, change the data source: select Context data from the drop-down list.
  10. Luego, haga clic en Advanced settings y seleccione el vínculo a los registros de entrega de los destinatarios.
  11. In the Chart type section, select the Email domain variable.
  12. A continuación, añada el cálculo que desea llevar a cabo: seleccione la suma como operador.
  13. Haga clic en el botón Detail para seleccionar el campo al que corresponda el recuento y cierre la ventana de configuración.
  14. Guarde el informe.
    La página está configurada.

Paso 6: Visualización del informe

Para visualizar el resultado de esta configuración, haga clic en la pestaña Preview y seleccione la opción Global .
La primera página del informe detalla la lista de todas las entregas incluidos en la base de datos.
Si hace clic en el vínculo de uno de estos entregas, se muestra el gráfico con el desglose de los dominios de correo electrónico para esta entrega. Ahora se encuentra en la segunda página del informe y puede regresar a la página anterior haciendo clic en el botón correspondiente.

Creación de un desglose o tabla dinámica

Este tipo de tabla le permite mostrar estadísticas calculadas en los datos de la base de datos.
El asistente de análisis descriptivo utiliza una configuración similar a estos tipos de informes. Para obtener más información, consulte esta página .
Para obtener más información sobre la creación de una tabla dinámica, consulte esta sección .