Show Menu
TEMAS×

Uso de Maven para comunidades

Información general

Esta sección de la documentación de AEM Communities se suma a:
Ahora hay dos artefactos "uber" que reemplazan a artefactos individuales:

Artificio Jar API de Communities

A continuación se muestra un ejemplo de GAV para el tarro de API de AEM Communities:
<dependency>
    <groupId>com.adobe.cq.social</groupId>
    <artifactId>cq-socialcommunities-api</artifactId>
    <version>1.11.170</version>
    <scope>provided</scope>
</dependency>

Asegúrese de que la versión especificada se corresponde con la versión del paquete Communities instalada para AEM Communities. Para verificar el número de versión instalada:
  1. Inicie sesión con privilegios administrativos.
  2. Vaya al Administrador de paquetes . Por ejemplo, http://localhost:4502/crx/packmgr/
  3. Busque el paquete: cq-socialcommunities-pkg-1.x.xxx
  4. Extraiga la versión del nombre del paquete:
    • La primera versión de AEM 6.3 es la versión 1.11.170.
    • Los paquetes de funciones serán las versiones 1.12.xxx.
Se recomienda mantenerse al día con la última versión de Comunidades.
Visite la sección Últimas versiones para identificar la versión más reciente.

Ejemplo de dependencia de Maven

El jar de API de Communities debe especificarse antes del jar de la API de Uber.
<dependency>
    <groupId>com.adobe.cq.social</groupId>
    <artifactId>cq-socialcommunities-api</artifactId>
    <version>1.11.170</version>
    <scope>provided</scope>
</dependency>
<dependency>
    <groupId>com.adobe.aem</groupId>
    <artifactId>uber-jar</artifactId>
    <version>6.3.0</version>
    <scope>provided</scope>
    <classifier>apis</classifier>
</dependency>