Show Menu
SUJETS×

Fonctionnalités obsolètes et supprimées

Adobe évalue constamment les fonctionnalités des produits pour identifier celles qui devraient être remplacées par des solutions plus modernes afin d’offrir une plus grande valeur ajoutée, et ce en prenant toujours en compte la rétrocompatibilité Comme Adobe Campaign Classic fonctionne avec des outils tiers, la compatibilité est régulièrement mise à jour pour ne mettre en œuvre que des versions prises en charge. Les versions devenues incompatibles avec Adobe Campaign Classic sont répertoriées ci-dessous et dans la matrice de compatibilité .
Lors de l’annonce de la suppression ou du remplacement imminent de fonctionnalités de Campaign Classic, les règles suivantes s’appliquent :
  • L’annonce de l’obsolescence vient en premier. Les fonctionnalités obsolètes sont encore disponibles et prises en charge pour les utilisateurs existants, mais elles ne seront plus améliorées ni documentées.
  • La suppression de fonctionnalités obsolètes aura lieu au plus tôt dans la version suivante. La date de suppression prévue est annoncée sur cette page.
Cette procédure laisse aux clients au moins un cycle de publication pour s’adapter à une nouvelle version ou au successeur d’une fonctionnalité supprimée avant la suppression définitive.
Les versions et nouvelles fonctionnalités d’Adobe Campaign sont répertoriées dans les Notes de mise à jour .

Fonctionnalités obsolètes

Cette section répertorie les fonctions et fonctionnalités qui ont été désignées comme étant obsolètes dans les dernières versions de Campaign Classic.
En règle générale, les fonctionnalités qui doivent être supprimées dans une version ultérieure sont définies comme étant obsolètes dans un premier temps. Ces fonctions et fonctionnalités ne sont plus disponibles pour les nouveaux clients de Campaign Classic ou ne doivent pas être utilisées dans le cadre d’une nouvelle implémentation. Elles sont également supprimées de la documentation du produit.
Il est conseillé aux clients d’évaluer dans quelle mesure ils utilisent la fonctionnalité dans leur déploiement actuel et d’envisager de modifier leur implémentation. Référez-vous aux dates de suppression prévues pour planifier les mises à jour de votre environnement et de vos projets en conséquence.
Fonctionnalité Remplacement
Connecteurs SMS
À compter de la version 20.2 de Campaign, les connecteurs SMS suivants sont obsolètes.
  • NetSize
  • SMPP générique (SMPP version 3.4 avec prise en charge du mode binaire)
  • Sybase365 (SAP SMS 365)
  • CLX Communications
  • Tele2
  • O2
  • iOS
Si vous utilisez l’un de ces connecteurs, vous devez adapter votre implémentation en conséquence. En savoir plus
Découvrez comment effectuer la migration des anciens connecteurs dans cette note technique .
Date de suppression prévue : 2021
Canal fax
À compter de la version 20.2 de Campaign, le canal Fax est obsolète.
Si vous utilisez ce canal, vous devez adapter votre implémentation en conséquence. En savoir plus sur les canaux de Campaign.
Date de suppression prévue : 2021

Fonctionnalités supprimées

Cette section répertorie les fonctionnalités supprimées de Campaign Classic.
Domaine - Fonctionnalité Remplacement
Archivage des emails basé sur les fichiers
Depuis la version 20.2 de Campaign, l’archivage des emails basé sur les fichiers n’est plus disponible. L’archivage des emails est désormais disponible par le biais d’une adresse de messagerie Cci dédiée. En savoir plus
Gestion des leads
À compter de la version 20.2 de Campaign, le module Gestion des leads n’est plus disponible. Il est possible de mettre en œuvre des fonctionnalités similaires à l’aide d’autres activités de workflow natives et des modifications de modèles de données.
Documentation des API de Campaign - fichier jsapi.chm Depuis la version 19.1 de Campaign, les API de Campaign Classic sont disponibles dans une page dédiée. Si vous utilisiez l’ancien fichier jsapi.chm, vous devez maintenant vous référer à la nouvelle version en ligne .
Orchestration de campagnes - Marketing prédictif À compter de la version 18.10 de Campaign, les fonctionnalités de marketing prédictif ne sont plus disponibles.
Applications web - Microsites À compter de la version 18.10 de Campaign, les microsites ne sont plus disponibles. Vous pouvez améliorer la sécurité en limitant l’accès aux seuls domaines dédiés des fichiers de configuration d’Adobe Campaign et utiliser des URL personnalisées dans Campaign à l’aide d’alias DNS. En savoir plus
Notifications push - Connecteur binaire iOS Selon la recommandation d’Apple, Adobe a supprimé l’ancien connecteur binaire iOS à compter de la version 18.10 de Campaign. Le connecteur HTTP/2, plus performant et plus efficace, est déjà disponible.
API decryptString
À compter de la version 18.6 de Campaign, pour des raisons de sécurité, l’API decryptString n’est plus disponible par défaut pour les nouvelles installations.
Dans le contexte d’un postupgrade vers la version 18.6 (et versions ultérieures), cette API n’est plus activée et a été remplacée par la fonction decryptPassword. En savoir plus
Canal mobile - Messages MMS et WAP Push À compter de la version 18.4 de Campaign, les canaux MMS et Wap Push ne sont plus disponibles. À titre de remplacement, vous pouvez tirer parti des diffusions SMS et Push .
Canal mobile - LINE v1 À compter de la version 18.4 de Campaign, le package LINE Connect n’est plus disponible. Adobe recommande d’utiliser le nouveau package Canal LINE pour le remplacer. En savoir plus

Compatibilité obsolète

Les systèmes suivants sont désormais obsolètes pour Campaign Classic : Reportez-vous à la matrice de compatibilité pour effectuer une mise à jour vers une nouvelle version ou passer à un nouveau système avant la fin de la compatibilité.

Adobe Campaign version 20.2

À compter de la version 20.2, les systèmes suivants sont obsolètes pour Campaign Classic. La compatibilité prendra fin avec la version 20.3 - Octobre 2020.

Adobe Campaign version 19.2

À compter de la version 19.2, les systèmes d’exploitation suivants sont obsolètes pour Campaign Classic. La compatibilité ne sera plus assurée à partir de la fin de l’année 2020.
  • Serveur Web : Apache 2.2.
  • Système d’exploitation : CentOS 6.
Reportez-vous à la matrice de compatibilité pour effectuer une mise à jour vers une nouvelle version ou passer à un nouveau système.

Fin de compatibilité

Adobe Campaign Classic est compatible avec tous les systèmes et outils répertoriés dans la matrice de compatibilité . Lorsque des versions spécifiques de ces systèmes et outils tiers arrivent en fin de vie (EOL) avec leurs créateurs respectifs, Adobe Campaign n’est plus compatible avec celles-ci : elles sont déclarées obsolètes, puis supprimées de la matrice de compatibilité pour la version suivante du produit. Pour éviter tout problème, vérifiez que vous disposez des versions prises en charge des systèmes répertoriés dans la matrice de compatibilité.

Console cliente

La console cliente d’Adobe Campaign Classic ne peut plus s’exécuter sur les systèmes suivants, car ils ont été abandonnés par leur éditeur. Les clients qui utilisent la console cliente de Campaign sur l’une de ces versions doivent effectuer la mise à niveau vers la version la plus récente avant la date de suppression prévue. Reportez-vous à la matrice de compatibilité .
  • Windows Server 2003, 2008, 2008 R2
  • Windows XP, Vista
À compter de la version 20.1 de Campaign, la console cliente 32 bits de Campaign Classic n’est plus compatible avec les dernières versions de Campaign. Vous devez utiliser la console cliente 64 bits.

Systèmes d’exploitation

Depuis la version 19.1, Adobe Campaign n’est plus compatible avec les systèmes d’exploitation ci-après.

Serveurs web

Depuis la version 19.1 du printemps, Adobe Campaign n’est plus compatible avec les serveurs web ci-après.

Outils

Depuis la version 19.1 du printemps, Adobe Campaign n’est plus compatible avec les outils ci-après.

Moteurs de base de données

Adobe ne prend pas en charge les moteurs de base de données ci-après, car ils ont été abandonnés par leur éditeur. Les clients utilisant ces versions doivent effectuer la mise à niveau vers la version la plus récente ou passer à une autre.
Consultez la matrice de compatibilité de Campaign  pour accéder à la liste des versions compatibles.
FEDERATED DATA ACCESS (FDA)
Depuis la version 19.1 du printemps, Adobe Campaign n’est plus compatible avec les serveurs FDA ci-après.
Campaign Classic n’est pas compatible avec les serveurs ci-après dans Federated Data Access (FDA).
  • DB2 UDB 9.5, 9.7. Une version plus récente de DB2 est prise en charge via Federated Data Access (FDA). En savoir plus
  • Oracle 9i, 10G R2. Les versions plus récentes d’Oracle sont prises en charge via Federated Data Access (FDA). En savoir plus
  • PostgreSQL 8.3, 8.4, 9.0, 9.1, 9.2. Les versions plus récentes de PostgreSQL sont prises en charge via Federated Data Access (FDA). En savoir plus
  • MSSQL 2000, 2005, 2008 R2. Les versions plus récentes de SQL Server sont prises en charge via Federated Data Access (FDA). En savoir plus
  • MySQL 5.1. Les versions plus récentes de MySQL sont prises en charge via Federated Data Access (FDA). En savoir plus
  • InfiniDB a atteint sa fin de vie. En savoir plus
  • Teradata 13, 13.1. Des versions plus récentes de Teradata sont prises en charge via Federated Data Access (FDA). En savoir plus
  • Netezza 6.02, 7.0. Netezza a atteint sa fin de vie. En savoir plus
  • AsterData 5.0. AsterData a atteint sa fin de vie. En savoir plus
  • Sybase IQ 15.2, 15.4, 15.5 et Sybase ASE 15.0. Des versions plus récentes de Sybase sont prises en charge par Federated Data Access (FDA). En savoir plus
  • Hadoop via HiveSQL : Hadoop 2.7.3, HiveSQL 1.2.1. Adobe Campaign Classic continuera à prendre en charge les versions répertoriées de Hadoop via HiveSQL par le biais de Federated Data Access (FDA), mais ces versions sont fusionnées avec : HortonWorks (HDP 2.4.X, 2.5.x, 2.6.x) et HDInsight 3.4 (HDP 2.4), 3.5 (HDP 2.5), 3.6 (HDP 2.6)
SERVEUR SGBDR
Adobe Campaign n’est pas compatible avec les serveurs SGBDR suivants :
  • Oracle 10GR2
  • PostgreSQL 9.0 à 9.3
  • SQL Server 2005
  • MySQL 5.1
  • DB2 UDB 9.7