Show Menu
SUJETS×

Créer un tableau

Vous pouvez ajouter un tableau dans un rapport afin d'afficher les données. Il peut s'agir d'un tableau croisé dynamique, créé à travers les mesures d'un cube, d'une liste avec groupement ou d'un tableau de distribution des valeurs.

Créer une liste avec groupement

Un tableau de type Liste avec groupement vous permet de regrouper certaines de vos données dans le tableau et de produire des statistiques sur les données qu'il contient. Vous pouvez par exemple créer des totaux et des sous-totaux sur les données. Chaque groupement contient une ligne d'en-tête, de détail et de pied.
L'activité Page qui contient le tableau doit être précédée d'une activité Requête ou Script afin de collecter les données qui seront analysées dans le rapport. Voir à ce sujet les sections Collecter les données à analyser et Activité Script .

Principe de fonctionnement

Il se peut que vous ayez besoin d'analyser plusieurs catégories de données à la fois. Une liste avec groupement vous permet de rassembler certaines données et de faire des statistiques sur différents groupes de données dans le même tableau. Pour ce faire, vous pouvez créer un groupement dans le tableau.
Dans l'exemple ci-dessous, le groupement fait apparaître l'ensemble des opérations de votre base, les diffusions et le nombre de messages envoyés par diffusion et par opération.
Il permet de répertorier la liste des opérations ( Libellé (Opération) ), la liste des diffusions ( Libellé ) rattachées à l'opération et de comptabiliser le nombre de messages envoyés pour chaque diffusion ( Traités ), puis de les additionner pour chaque opération ( Sum(@processed) ).

Etapes de mise en oeuvre

Un exemple complet de mise en œuvre est proposé ici : Cas pratique : créer un rapport avec une liste avec groupement .
Toutefois, notez que les étapes de création d'un tableau de type 'Liste avec groupement' sont les suivantes :
  1. Dans le diagramme d'un rapport, positionnez une activité Requête . Voir à ce sujet la section Collecter les données à analyser .
  2. Renseigner la table source et sélectionner les champs de la table sur lesquels porteront les statistiques.
  3. Positionnez une activité Page dans le diagramme. Voir à ce sujet la section Eléments statiques .
  4. Insérer un tableau de type Liste avec groupement dans la page.
  5. Indiquer le chemin des données, soit la table choisie comme source de données dans la requête.
    Cette étape est indispensable pour retrouver les champs de la table source et les insérer par la suite dans les cellules du tableau.
  6. Créer le tableau et son contenu.
  7. Affichez le rapport finalisé dans l'onglet Prévisualisation . Vous pouvez ensuite publier le rapport et l'exporter vers un autre format. Voir à ce sujet la section Exporter un rapport .

Ajouter des lignes et des colonnes

Un tableau de type Liste avec groupement est composé par défaut d'une ligne d'en-tête, d'une ligne de détail et d'une ligne de pied.
Un groupement contient lui-même une ligne d'en-tête, de détail et de pied.
  • Ligne d'en-tête : elle permet de donner un titre aux colonnes du tableau.
  • Ligne de détail : elle contient les valeurs des statistiques.
  • Ligne de pied : permet d'afficher les totaux des statistiques.
Vous pouvez ajouter des colonnes et des lignes selon vos besoins.
Le groupement peut être positionné dans n'importe quelle ligne du tableau et est lui-même composé d'une ligne d'en-tête, de détail et de pied.
Ligne et colonne : pour ajouter ou supprimer une ligne ou une colonne, positionnez-vous sur une ligne ou une colonne existante et utilisez les menus contextuels.
La nature de la ligne que vous ajoutez dépend de l'emplacement du curseur : par exemple, pour ajouter une ligne d'en-tête, vous devez positionner la souris sur un en-tête puis cliquer sur Ajouter > Une ligne au-dessus/dessous .
La largeur des colonnes peut être modifiée à partir de l'entrée Format de la colonne .
Groupement : de même, pour ajouter un groupement, positionnez-vous sur une ligne et sélectionnez l'entrée correspondante dans le menu contextuel.

Définir le contenu des cellules

Pour éditer une cellule du tableau et définir son contenu et son format, cliquez dans la cellule et utilisez le menu contextuel.
Utilisez l'entrée de menu Expression pour sélectionner les valeurs à afficher.
  • Si vous souhaitez insérer les valeurs à analyser directement dans le tableau, sélectionnez-les parmi les champs disponibles.
    La liste des champs disponibles correspond au contenu de la requête précédant le tableau dans le diagramme de construction du rapport.
  • Saisir un libellé dans une cellule, par exemple dans une cellule d'en-tête.
    Pour cela, procédez comme pour insérer un champ de la base mais ne sélectionnez aucune expression. Saisissez le libellé dans le champ Libellé : il sera affiché tel quel.
  • Calculer un agrégat (une moyenne, une somme, etc.) et l'afficher dans une cellule.
    Pour cela, utilisez l'entrée de menu Agrégats et sélectionnez l'opération voulue.

Définir le format des cellules

Pour définir le format de cellule, le menu Format de la cellule... permet d'accéder à toutes les options de formatage disponibles pour la cellule sélectionnée.
Ces options permettent de personnaliser le rendu final du rapport et en optimiser la lisibilité des informations.
Utilisez le champ Retour à la ligne dans le cadre d'un export des données vers Excel : choisissez la valeur Oui pour forcer le retour à la ligne. Cette valeur sera conservée lors de l'export. Voir à ce sujet la section Exporter un rapport .
La fenêtre Format de la cellule , vous permet d'accéder aux onglets suivants :
  • l'onglet Valeur ,
  • l'onglet Bordures ,
  • l'onglet Clic ,
  • l'onglet Plus .
L'onglet Valeur permet de modifier la police et les différents attributs des valeurs ou leur définir un format selon leur nature.
Le format modifie l'affichage des données : par exemple, les formats Nombre , Monétaire et Pourcentage permettent d'aligner les chiffres à droite et de faire apparaître des décimales.
Exemple de paramétrage d'un format monétaire : vous pouvez indiquer la monnaie dans laquelle sont exprimées les valeurs, utiliser ou non le séparateur de milliers et afficher en rouge les valeurs négatives. La position du symbole monétaire dépend de la langue de l'opérateur, telle qu'elle a été définie dans son profil.
Exemple de paramétrage pour les dates : vous pouvez choisir d'afficher l'heure ou non.
L'onglet Bordures permet de d'ajouter des bordures aux lignes et colonnes du tableau. L'ajout de bordures au niveau des cellules peut provoquer des problèmes de performance lors de l'export des rapports les plus volumineux sous Excel.
Au besoin, vous pouvez définir les bordures au niveau du modèle du tableau ( Administration > Paramétrage > Rendus des formulaires ).
La syntaxe sera alors du type :
dans l'onglet Web :
 .tabular td {
 border: solid 1px #000000;
 }

dans l'onglet Excel :
 <style name="odd" fillColor="#fdfdfd">
  <border>
   <borderTop value="solid 0.05pt #000000" />
   <borderBottom value="solid 0.05pt #000000" />
   <borderLeft value="solid 0.05pt #000000" />
   <borderRight value="solid 0.05pt #000000" />
  </border>
 </style> 
 
 <style name="even" fillColor="#f7f8fa">
  <border>
   <borderTop value="solid 0.05pt #000000" />
   <borderBottom value="solid 0.05pt #000000" />
   <borderLeft value="solid 0.05pt #000000" />
   <borderRight value="solid 0.05pt #000000" />
  </border>
 </style> 

L'onglet Clic permet de définir une action lorsque l'utilisateur clique sur le contenu d'une cellule du tableau.
Dans l'exemple ci-dessous, cliquer sur la valeur dans la cellule vous permet d'afficher à la deuxième page du rapport : elle contiendra les informations relatives à la diffusion contenue dans la cellule.
L'onglet Plus permet d'associer un visuel sur vos données une pastille de couleur ou une barre de valeur. La pastille de couleur est utilisée lorsque le tableau est affiché comme légende d'un graphique. Voir à ce propos l'exemple de mise en œuvre : Etape 5- Créez la seconde page

Cas pratique : créer un rapport avec une liste avec groupement

Dans cet exemple, vous allez créer un rapport de deux pages : la première page contiendra la liste et le total des diffusions par opération, ainsi que le nombre de messages envoyés. L'intitulé des diffusions sera sous forme de lien cliquable et permettra de passer à la deuxième page du rapport pour visualiser la répartition des envois par domaine d'email pour la diffusion choisie avec un tableau et un graphique. Dans la seconde page, le tableau servira de légende au graphique.

Etape 1 - Créer un rapport

Créez un nouveau rapport qui porte sur le schéma des opérations : Opérations (nms) .
Cliquez sur Enregistrer pour créer le rapport.
Positionnez dans le diagramme les premiers composants qui vont être utilisés pour concevoir le contenu du rapport : une première requête et une première page.

Etape 2 - Créer la première requête

La première requête permet de collecter les diffusions associées à chaque opération. L'objectif est d'afficher un rapport sur les différentes diffusions de la base Adobe Campaign qui sont liées à chaque opération.
Double-cliquez sur la première requête pour l'éditer, puis respectez les étapes suivantes pour la paramétrer :
  1. Modifiez d'abord le schéma sur lequel la source de la requête porte : choisissez le schéma Diffusions (nms) .
  2. Cliquez sur le lien Editez la requête , affichez les champs avancés.
  3. Sélectionnez les champs suivants :
    • le libellé de la diffusion,
    • la clé primaire de la diffusion,
    • le libellé de l'opération,
    • l'indicateur des diffusions traitées,
    • la clé étrangère du lien Opération,
    • l'indicateur du taux d'erreur.
    Associez un alias à chaque champ : cette opération est recommandée afin de faciliter la sélection des données du tableau qui sera ajouté dans la première page du rapport.
    Dans cet exemple, nous utiliserons les alias suivants :
    • Libellé : @label
    • Clé primaire : @deliveryId
    • Libellé (Opération) : @label1
    • Traités : @processed
    • Clé étrangère du lien 'Opération' (champ'id') : @operationId
    • Taux d'erreur : @errorRatio
  4. Cliquez deux fois sur le bouton Suivant , jusqu'à l'étape Filtrage des données .
    Ajoutez une condition de filtrage afin de ne collecter que les diffusions rattachées à une opération.
    La syntaxe de ce filtre est la suivante : "Clé étrangère du lien 'Opération' supérieur à 0".
  5. Cliquez sur Terminer pour enregistrez ces conditions puis sur Ok pour fermer l'éditeur de requête.

Etape 3 - Créez la première page

Dans cette étape, nous allons paramétrer la première page du rapport. Pour la configurer, les étapes sont les suivantes :
  1. Ouvrez l'activité Page et saisissez son titre, par exemple ici : Diffusions .
  2. Insérez une liste avec groupement à partir de la barre d'outils et saisissez son libellé, par exemple ici : Liste des diffusions par opération.
  3. Cliquez sur le lien Chemin des données du tableau et sélectionnez le lien des diffusions, soit [query/delivery]
  4. Cliquez sur l'onglet Données et modifiez l'aspect du tableau : ajoutez trois colonnes à droite.
  5. Ajoutez un groupement.
    Ce groupement va vous permettre de regrouper les opérations et les diffusions qui y sont rattachées.
  6. Dans la fenêtre du groupement, référencez la Clé étrangère du lien 'Opération' puis fermez la fenêtre.
  7. Editez la première cellule de l'en-tête de groupement et insérez le champ Libellé des opérations comme expression.
  8. Editez la 2e cellule de la ligne de détails et choisissez le champ Libellé des diffusions.
  9. Editez le format de cette cellule et ouvrez l'onglet Clic . Paramétrez les options adéquates pour que lorsque l'utilisateur clique dans le nom d'une diffusion, elle s'ouvre dans la même fenêtre.
    Pour cela, sélectionnez une action de type Page suivante avec l'option d'ouverture Dans la même fenêtre .
  10. Dans la section inférieure de la fenêtre, cliquez sur Ajouter et indiquez le chemin /vars/selectedDelivery et l'expression @deliveryId , qui correspond à l'alias de la clé primaire de la diffusion, tel que défini dans la requête créée précédemment. Cette formule permet d'accéder à la diffusion sélectionnée.
  11. Editez la 2e cellule de la ligne de pied du groupement et saisissez le libellé Total par opération .
  12. Editez la 3e cellule de la ligne d'en-tête du groupement et saisissez le libellé Nombre de messages envoyés .
    Cette information correspond au titre de la colonne.
  13. Editez la 3e cellule de la ligne de détail et sélectionnez l'indicateur des messages traités comme expression.
  14. Editez la 3e cellule de la ligne de pied du groupement, sélectionnez l'indicateur des diffusions traitées et appliquez-lui l'agrégat Somme .
  15. Editez la 4e cellule de la ligne de détail et sélectionnez l'expression Taux d'erreur des diffusions .
  16. Sélectionnez cette cellule pour afficher une barre de valeur pour représenter le taux d'erreur des diffusions.
    Pour cela, accédez au format de la cellule puis à l'onglet Plus . Choisissez ensuite l'entrée Barre de valeur dans la liste déroulante et sélectionnez l'option Cacher la valeur de la cellule .
    Vous pouvez dès à présent visualiser le rendu de ce rapport. Cliquez sur l'onglet Prévisualisation et sélectionnez l'option Global : vous affichez ainsi la liste de toutes les diffusions de la base Adobe Campaign qui sont liées à une opération.
    Il est conseillé d'utiliser l'onglet Aperçu pour vérifier que vous avez sélectionné et correctement paramétré les données de votre tableau. Cette vérification faite, vous pouvez passer au formatage de votre tableau.
  17. Appliquez le style Gras aux cellules contenant le total par opération et la somme des messages traités.
  18. Cliquez sur la 1ère cellule de la ligne d'en-tête du groupement, celle qui affiche le nom de l'opération, et choisissez Editer > Fusionner à droite .
    En fusionnant les deux premières cellules de la ligne d'en-tête du groupement, vous allez diminuer le décalage entre le titre de l'opération et la liste des diffusions qui y sont rattachées.
    Il est vivement recommandé de ne fusionner des cellules que lorsque votre rapport est déjà construit, car cette opération ne peut pas être annulée.

Etape 4 - Créez la seconde requête

Nous allons ajouter une seconde requête et une seconde page afin d'afficher le détail d'une diffusion lorsque l'utilisateur du rapport clique dessus. Avant d'ajouter la requête, éditez la page que vous avez créée et activez la transition sortante afin de pouvoir la relier à la requête.
  1. Ajoutez une nouvelle requête à la suite de l'activité Page et modifiez le schéma sur lequel elle porte : choisissez le schéma Logs de diffusion des destinataires .
  2. Editez la requête et définissez les colonnes de sortie. Afin d'afficher le nombre de diffusions par domaine d'email, vous devez :
    • calculer la somme des clés primaires, afin de compter le nombre de logs de diffusion :
    • collecter les domaines des emails des destinataires et regrouper les informations sur ce champ : pour cela, sélectionnez l'option Grouper sur la colonne du nom de domaine.
    Associez les alias suivants aux champs :
    • count(clé primaire) : @count
    • Domaine de l'email (Destinataire) : @domain
  3. Cliquez deux fois sur le bouton Suivant , jusqu'à l'étape Filtrage des données .
    Ajoutez une condition de filtrage afin de ne collecter que les informations liées à la diffusion sélectionnée.
    La syntaxe est la suivante : Clé étrangère du lien 'Diffusion' égale à la valeur du paramètre $([vars/selectedDelivery])
  4. Fermez la fenêtre de paramétrage de la requête et ajoutez une page dans le diagramme, à la suite de cette deuxième requête.

Etape 5- Créez la seconde page

  1. Editez la page et saisissez son libellé, ici : Domaines d'email .
  2. Décochez l'option Activer les transitions sortantes : cette page est la dernière du rapport et ne sera suivie d'aucune activité supplémentaire.
  3. Ajoutez une nouvelle liste avec groupement à l'aide du menu contextuel et nommez-la Domaines d'email par destinataires .
  4. Cliquez sur le lien Chemin des données du tableau et sélectionnez le lien Logs de diffusion des destinataires .
  5. Dans l'onglet Données , adaptez le tableau comme suit :
    • Ajoutez deux colonnes supplémentaires à droite.
    • Dans la 1ère cellule de la ligne de détail, ajoutez l'expression rowNum()-1 afin de compter le nombre de lignes. Puis modifiez le format de cellule : dans l'onglet Plus , sélectionnez Pastille de couleur et cliquez sur Ok .
      Ce paramétrage va vous permettre d'utiliser le tableau comme légende pour le graphique.
    • Dans la 2e cellule de la ligne de détail, ajoutez l'expression Domaine de l&#39;email(Destinataire) .
    • Dans la 3e cellule de la ligne de détail, ajoutez l'expression count(clé primaire) .
  6. Ajoutez un graphique en secteurs dans la page à l'aide du menu contextuel et attribuez-lui le libellé Domaines d'email . Voir à ce sujet la section Types de graphiques et leurs variantes .
  7. Cliquez sur le lien Variantes et déselectionnez les options Afficher les libellés et Afficher la légende .
  8. Vérifiez qu'aucun tri de valeurs n'est paramétré. Reportez-vous à cette section pour plus d'informations sur ce sujet.
  9. Dans l'onglet Données , modifiez la source de données : choisissez Données du contexte dans la liste déroulante.
  10. Puis cliquez sur Paramètres avancés et choisissez le lien des logs de diffusion des destinataires.
  11. Dans la partie Nature du graphe , sélectionnez la variable Domaine de l&#39;email .
  12. Ajoutez ensuite le calcul à effectuer : choisissez la somme comme opérateur.
  13. Cliquez sur le bouton Détail pour choisir le champ sur lequel va porter le comptage, puis fermez la fenêtre de configuration de la page.
  14. Enregistrez le rapport.
    Votre page est à présent paramétrée.

Etape 6 - Visualiser le rapport

Pour visualiser le résultat de ce paramétrage, cliquez sur l'onglet Prévisualisation puis sélectionnez l'option Global .
La première page de votre rapport présente la liste de toutes les diffusions contenues dans la base de données.
Si vous cliquez sur le lien d'une des diffusions, le graphique représentant la répartition par domaine d'email pour cette diffusion s'affiche. Vous êtes sur la deuxième page de votre rapport et avez la possibilité de revenir à la page précédente en cliquant sur le bouton approprié.

Créer un tableau de distribution ou croisé dynamique

Ce type de tableau vous permet d'afficher des statistiques calculées sur les données de la base.
Les paramètres de création de ce type de rapport sont similaires à ceux utilisés pour l'assistant d'analyse descriptive. Voir à ce propos cette page .
La création d'un tableau croisé dynamique est présentée dans cette section .