Show Menu
ARGOMENTI×

Funzioni obsolete e rimosse

Adobe valuta costantemente le funzionalità dei prodotti per identificare le funzioni meno recenti da sostituire con alternative più moderne, al fine di migliorare il valore complessivo dei clienti, sempre con un'attenta considerazione della compatibilità con le versioni precedenti. Poiché Adobe Campaign Classic funziona con strumenti di terze parti, la compatibilità viene aggiornata regolarmente, al fine di implementare solo le versioni supportate. Le versioni non più compatibili con Adobe Campaign Classic sono elencate di seguito e nella matrice di compatibilità.
Per comunicare l'imminente rimozione/sostituzione delle funzionalità di Campaign Classic, si applicano le regole seguenti:
  • L'annuncio della deprecazione viene prima. Le funzionalità obsolete possono essere ancora disponibili e supportate per gli utenti esistenti, ma non saranno ulteriormente migliorate né documentate.
  • La rimozione di funzionalità obsolete verrà effettuata non prima nella versione successiva. La data di destinazione effettiva per la rimozione è annunciata in questa pagina.
Questo processo offre ai clienti almeno un ciclo di rilascio per adattare la loro implementazione a una nuova versione o successore di una funzionalità obsoleta, prima della rimozione effettiva.
Le release di Adobe Campaign e le nuove funzionalità sono elencate nelle note sulla versione .

Deprecated features

In questa sezione sono elencate le funzionalità contrassegnate come obsolete con le ultime versioni di Campaign Classic.
In genere, le funzioni pianificate per essere rimosse in una versione futura sono impostate per prime come obsolete. Queste funzionalità non sono più disponibili per i nuovi clienti di Campaign Classic o non devono essere utilizzate per alcuna nuova implementazione. Vengono anche rimosse dalla documentazione del prodotto.
I clienti sono invitati a verificare se utilizzano la funzionalità o la funzionalità nella distribuzione corrente e a pianificare la modifica della loro implementazione. Fare riferimento alla data di rimozione della destinazione per pianificare l'ambiente e gli aggiornamenti del progetto di conseguenza.
Feature Sostituzione
Connettori SMS
A partire dalla release 20.2, i seguenti connettori SMS sono obsoleti.
  • NetSize
  • SMPP generico (SMPP versione 3.4 che supporta la modalità binaria)
  • Sybase365 (SAP SMS 365)
  • Comunicazioni CLX
  • Tele2
  • O2
  • iOS
Se si utilizza uno di questi connettori, è necessario adattare di conseguenza la propria implementazione. Ulteriori informazioni
Scopri come migrare i connettori legacy in questa nota tecnica .
Data di rimozione destinazione: 2021
Canale fax
A partire dalla release 20.2, il canale Fax è diventato obsoleto.
Se utilizzi questo canale, devi adattare di conseguenza la tua implementazione. Ulteriori informazioni sui canali Campaign.
Data di rimozione destinazione: 2021

Funzioni rimosse

In questa sezione sono elencate le funzionalità rimosse da Campaign Classic.
Area - Feature Sostituzione
Archiviazione delle e-mail basata su file
A partire dalla release di Campaign 20.2, l'archiviazione delle e-mail basate su file non è più disponibile. L'archiviazione delle e-mail è ora disponibile tramite un indirizzo e-mail CCN dedicato. Ulteriori informazioni
Gestione dei lead
A partire dalla release Campaign 20.2, il pacchetto Lead Management non è più disponibile. Funzionalità simili possono essere implementate tramite altre attività di flusso di lavoro native e modifiche apportate ai modelli di dati.
Documentazione sulle API delle campagne - file jsapi.chm A partire dalla release Campaign 19.1, le API Campaign Classic sono disponibili in una pagina dedicata. Se utilizzi il file jsapi.chm precedente, ora fai riferimento alla nuova versione index.html online.
Orchestrazione campagna - Predictive marketing A partire dalla versione Campaign 18.10, le funzionalità di marketing predittivo non sono più disponibili.
Applicazioni Web - Micrositi A partire dalla versione della campagna 18.10, i micrositi non sono più disponibili. Puoi migliorare la sicurezza limitando l'accesso solo ai domini dedicati nei file di configurazione di Adobe Campaign e utilizzando gli alias DNS per utilizzare gli URL personalizzati in Campaign. Ulteriori informazioni
Notifiche push - Connettore binario iOS In base alla raccomandazione di Apple, Adobe ha rimosso il connettore binario iOS legacy avviando la release 18.10 di Campaign. È già disponibile il connettore HTTP/2 più efficiente e potente.
decryptString API
A partire dalla release Campaign 18.6, per motivi di sicurezza, l'API decifrptString non è più disponibile per impostazione predefinita per le nuove installazioni.
Nel contesto di un post-aggiornamento a 18.6 (e versioni successive), questa API non viene più attivata ed è stata sostituita dalla funzione deryptPassword . Ulteriori informazioni
Canale mobile - Messaggi push MMS e WAP A partire dalla release Campaign 18.4, i canali MMS e Wap Push non sono più disponibili. In sostituzione, potete utilizzare gli SMS e le consegne push .
Canale mobile - LINE v1 A partire dalla versione di Campaign 18.4, il pacchetto LINE Connect non è più disponibile. Adobe consiglia di utilizzare il nuovo pacchetto LINE Channel come sostituzione. Ulteriori informazioni

Compatibilità obsoleta

I seguenti sistemi sono obsoleti per Campaign Classic. Fare riferimento alla matrice di compatibilità per effettuare l'aggiornamento a una versione più recente o per passare a un nuovo sistema prima del termine della compatibilità.

Versione di Adobe Campaign 20.2

A partire dalla versione 20.2, il sistema seguente è diventato obsoleto per Campaign Classic. La compatibilità terminerà con la release 20.3 - settembre 2020.
  • Console client: Windows 7
  • Connettori SMS legacy (vedere la sezione Funzioni obsolete di seguito)

Versione di Adobe Campaign 19.2

A partire dalla versione 19.2, i seguenti sistemi operativi sono obsoleti per Campaign Classic. La compatibilità terminerà nel 2020.
  • Server Web: Apache 2.2.
  • Sistema operativo: CentOS 6.
Fare riferimento alla matrice di compatibilità per effettuare l'aggiornamento a una versione più recente o passare a un nuovo sistema.

Fine della compatibilità

Adobe Campaign Classic è compatibile con tutti i sistemi e gli strumenti elencati nella matrice di compatibilità. Quando versioni specifiche di questi sistemi e strumenti di terze parti raggiungono la fine del ciclo di vita (EOL) con i rispettivi creatori, Adobe Campaign non è più compatibile con tali versioni: vengono annunciati come obsoleti e quindi rimossi dalla nostra matrice di compatibilità nella release successiva del prodotto. Verificare di disporre delle versioni supportate di tutti i sistemi elencati nella matrice di compatibilità per evitare problemi.

Console client

Adobe Campaign Classic Client Console non può più essere eseguito sui seguenti sistemi perché è stato dichiarato obsoleto dal relativo editor. I clienti che eseguono Campaign Client Console in una di queste versioni devono effettuare l'aggiornamento alla versione più recente prima della data di rimozione del target. Fare riferimento alla matrice di compatibilità.
  • Windows Server 2003, 2008, 2008 R2
  • Windows XP, Vista
A partire dalla versione di Campaign 20.1, Campaign Classic Client Console 32 bit non è più compatibile con le versioni più recenti di Campaign. È necessario utilizzare la console client a 64 bit.

Sistemi operativi

A partire dalla versione 19.1, Adobe Campaign non è più compatibile con i seguenti sistemi operativi.

Server Web

A partire dalla release 19.1 di primavera, Adobe Campaign non è più compatibile con il seguente server Web.

Strumenti

A partire dalla release 19.1 di primavera, Adobe Campaign non è più compatibile con i seguenti strumenti.

Motori di database

Adobe non supporta i seguenti motori di database perché sono stati dichiarati obsoleti dal relativo editor. I clienti che eseguono queste versioni devono effettuare l'aggiornamento alla versione più recente o passare a un'altra.
Fare riferimento alla matrice di compatibilità di Campaign Classic per accedere all'elenco delle versioni compatibili.
FEDERATED DATA ACCESS (FDA)
A partire dalla release 19.1 di primavera, Adobe Campaign non è più compatibile con i seguenti server FDA.
Campaign Classic non è compatibile con i seguenti server in Federated Data Access (FDA).
  • DB2 UDB 9.5, 9.7. La versione più recente di DB2 è supportata tramite Federated Data Access (FDA). Ulteriori informazioni
  • Oracle 9i, 10G R2. Le versioni più recenti di Oracle sono supportate tramite Federated Data Access (FDA). Ulteriori informazioni
  • PostgreSQL 8.3, 8.4, 9.0, 9.1, 9.2. Versioni più recenti di PostgreSQL sono supportate tramite Federated Data Access (FDA). Ulteriori informazioni
  • MSSQL 2000, 2005, 2008 R2. Versioni più recenti di SQL Server sono supportate tramite Federated Data Access (FDA). Ulteriori informazioni
  • MySQL 5.1. Le versioni più recenti di MySQL sono supportate tramite Federated Data Access (FDA). Ulteriori informazioni
  • InfiniDB ha raggiunto la fine del ciclo di vita. Ulteriori informazioni
  • Teradata 13, 13.1. Versioni più recenti di Teradata sono supportate tramite Federated Data Access (FDA). Ulteriori informazioni
  • Netezza 6.02, 7.0. Netezza raggiunse la fine della vita. Ulteriori informazioni
  • AsterData 5.0. AsterData ha raggiunto la fine del ciclo di vita. Ulteriori informazioni
  • Sybase IQ 15.2, 15.4, 15.5 e Sybase ASE 15.0. Versioni più recenti di Sybase sono supportate tramite Federated Data Access (FDA). Ulteriori informazioni
  • Hadoop tramite HiveSQL: Hadoop 2.7.3, HiveSQL 1.2.1. Adobe Campaign Classic continuerà a supportare le versioni elencate di Hadoop tramite HiveSQL tramite Federated Data Access (FDA), ma queste versioni vengono unite con: HortonWorks (HDP 2.4.X, 2.5.x, 2.6.x) e HDInsight 3.4 (HDP 2.4), 3.5 (HDP 2.5), 3.6 (HDP 2.6)
RDBMS SERVER
Adobe Campaign non è compatibile con i seguenti server RDBMS:
  • Oracle 10GR2
  • PostgreSQL da 9.0 a 9.3
  • SQL Server 2005
  • MySQL 5.1
  • DB2 UDB 9.7