Show Menu
ARGOMENTI×

Creazione di una tabella

Puoi aggiungere una tabella a un rapporto per visualizzare i dati. Può trattarsi di una tabella pivot creata in base a misure del cubo, un elenco con un gruppo o una tabella contenente una suddivisione di valori.

Creazione di un elenco con un gruppo

Una List with group tabella di tipo consente di raggruppare i dati nella tabella e di generare statistiche su di essa. Ad esempio, è possibile creare totali e subtotali per i dati. Ogni gruppo ha una propria riga di intestazione, dettaglio e piè di pagina.
L' Page attività che contiene la tabella deve essere preceduta da un' Query attività o Script attività per raccogliere i dati da analizzare nel rapporto. Per ulteriori informazioni su queste attività, vedere Raccolta di dati per l'analisi e l'attività Attività script Script.

Principio di funzionamento

Può accadere che sia necessario analizzare più categorie di dati contemporaneamente. Un elenco con un gruppo consente di combinare i dati e creare statistiche su vari gruppi di dati all’interno della stessa tabella. A questo scopo, potete creare un gruppo nella tabella.
Nell'esempio seguente, il gruppo mostra tutte le campagne nel database, le consegne e il numero di messaggi inviati per consegna e per campagna.
Consente di elencare le campagne ( Label (Campaign) , l'elenco delle consegne ( Label ) collegate alla campagna e di calcolare il numero di messaggi inviati per consegna ( Processed) , prima di aggiungerli per ogni campagna ( Sum(@processed) ).

Passaggi di implementazione

Un esempio completo di implementazione è fornito qui: Caso di utilizzo: Creare un rapporto con un elenco di gruppi.
Per creare una tabella di tipo 'Elenco con gruppo', attenersi alla procedura seguente:
  1. Passate al grafico del rapporto e inserite un' Query attività. Fare riferimento a Raccolta di dati da analizzare .
  2. Compila la tabella di origine e seleziona i campi della tabella che saranno interessati dalle statistiche.
  3. Inserite un' Page attività nel grafico. Per ulteriori informazioni, vedere Elementi statici.
  4. Inserire una tabella List with group di tipo nella pagina.
  5. Specificare il percorso dati o la tabella selezionata come origine dati nella query.
    Questo passaggio è obbligatorio se si desidera recuperare i campi nella tabella di origine in un secondo momento e inserirli nelle celle della tabella.
  6. Creazione della tabella e del relativo contenuto.
  7. Visualizza il rapporto finale nella Preview scheda. Potete quindi pubblicare il rapporto ed esportarlo in un formato diverso, se necessario. Per ulteriori informazioni, vedere Esportazione di un rapporto .

Aggiunta di righe e colonne

Per impostazione predefinita, una tabella di tipo List with group include un'intestazione, una riga di dettaglio e una riga piè di pagina.
Il gruppo stesso include righe di intestazione, dettagli e piè di pagina.
  • Riga di intestazione: questa riga consente di assegnare un titolo alle colonne della tabella.
  • Linea dettagli: questa riga contiene valori statistici.
  • Riga piè di pagina: questa riga consente di visualizzare i valori totali.
È possibile aggiungere righe e colonne in base alle proprie esigenze.
Il gruppo può essere posizionato su qualsiasi riga della tabella e include righe di intestazione, dettagli e piè di pagina personalizzate.
Riga e colonna : per aggiungere o eliminare una riga o una colonna, passare a una riga o colonna esistente e utilizzare il menu di scelta rapida.
La natura della linea aggiunta dipende dalla posizione del cursore. Ad esempio, per aggiungere una riga di intestazione, posizionare i cursori su un'intestazione, quindi fare clic Add > A line above/below .
La larghezza delle colonne può essere modificata tramite l’ Column format elemento.
Gruppo : per aggiungere un gruppo, passate a una riga e selezionate la voce corrispondente nel menu a discesa.

Definizione del contenuto delle celle

Per modificare una cella della tabella e definirne il contenuto e il formato, passare alla cella e utilizzare il menu di scelta rapida.
Utilizzate la voce di Expression menu per selezionare i valori da visualizzare.
  • Per inserire i valori da analizzare direttamente nella tabella, selezionarli tra i campi disponibili.
    L'elenco dei campi disponibili coincide con il contenuto della query prima della tabella nel grafico di costruzione del rapporto.
  • Immettete un'etichetta per una cella, ad esempio l'intestazione.
    A questo scopo, utilizzare lo stesso processo utilizzato per inserire un campo nel database, ma non selezionare un'espressione. Immettere l'etichetta nel Label campo. Verrà visualizzato così come è.
  • Calcolo di un aggregato (una media, una somma, ecc.) e visualizzarlo nella cella.
    A questo scopo, utilizzate la voce di Aggregates menu e selezionate la campagna desiderata.

Definizione del formato della cella

Per definire il formato della cella, il Cell format... menu consente di accedere a tutte le opzioni di formattazione disponibili per la cella selezionata.
Queste opzioni consentono di personalizzare il rendering finale del rapporto e semplificano la lettura delle informazioni.
Utilizzare il Carriage return campo durante l'esportazione dei dati in Excel: selezionare il Yes valore per forzare il ritorno a capo. Questo valore verrà mantenuto al momento dell'esportazione. Per ulteriori informazioni, vedere Esportazione di un rapporto .
La Cell format finestra consente di accedere alla scheda seguente:
  • La Value scheda
  • La Borders scheda
  • La Click scheda
  • La Extra scheda
La Value scheda consente di modificare il font e i vari attributi di valore o di definire un formato basato sulla loro natura.
Il formato modifica la visualizzazione dei dati: ad esempio, i Number formati Monetary e Percentage consentono di allineare le cifre sulla destra e visualizzare i punti decimali.
Esempio di configurazione di un formato di valuta: è possibile specificare la valuta in cui sono espressi i valori, scegliere se separarli o meno e visualizzare valori negativi in rosso. La posizione del simbolo di valuta dipende dalla lingua dell'operatore definita nel relativo profilo.
Esempio di configurazione per le date: è possibile scegliere se visualizzare o meno l'ora.
La scheda Bordi consente di aggiungere bordi alle righe e alle colonne della tabella. L'aggiunta di bordi alle celle potrebbe causare problemi di prestazioni durante l'esportazione di rapporti di grandi dimensioni in Excel.
Se necessario, è possibile definire i bordi nel modello di tabella ( Administration > Configuration > Form rendering ).
In questo caso, si avrà la sintassi seguente:
Nella scheda Web:
 .tabular td {
 border: solid 1px #000000;
 }

Nella scheda Excel:
 <style name="odd" fillColor="#fdfdfd">
  <border>
   <borderTop value="solid 0.05pt #000000" />
   <borderBottom value="solid 0.05pt #000000" />
   <borderLeft value="solid 0.05pt #000000" />
   <borderRight value="solid 0.05pt #000000" />
  </border>
 </style> 
 
 <style name="even" fillColor="#f7f8fa">
  <border>
   <borderTop value="solid 0.05pt #000000" />
   <borderBottom value="solid 0.05pt #000000" />
   <borderLeft value="solid 0.05pt #000000" />
   <borderRight value="solid 0.05pt #000000" />
  </border>
 </style> 

La Click scheda consente di definire un'azione quando l'utente fa clic sul contenuto di una cella o di una tabella.
Nell'esempio seguente, facendo clic sul valore nella cella è possibile visualizzare la seconda pagina del rapporto: conterrà informazioni sulla consegna nella cella.
La scheda Extra consente di collegare un elemento visivo ai dati, ad esempio un segno colorato o una barra dei valori. Il segno colorato viene utilizzato quando la tabella viene visualizzata come legenda in un grafico. Per ulteriori informazioni, consulta l’esempio di implementazione: Passo 5 - Creare la seconda pagina

Caso di utilizzo: Creare un rapporto con un elenco di gruppi

In questo esempio, verrà creato un rapporto di due pagine: la prima pagina conterrà l’elenco e il totale delle consegne per campagna, nonché il numero di messaggi inviati. I nomi delle consegne saranno cliccabili e potrai passare alla seconda pagina del rapporto per visualizzare la suddivisione delle consegne per dominio e-mail per la consegna selezionata con una tabella e un grafico. Nella seconda pagina, la tabella fungerà da legenda per il grafico.

Passaggio 1 - Creare un rapporto

Create un nuovo rapporto che riguardi lo schema della campagna, Campaigns (nms) .
Fate clic Save per creare il rapporto.
Passate al grafico e aggiungete i primi componenti da utilizzare per la progettazione del contenuto del rapporto: una prima query e una prima pagina.

Passaggio 2 - Creare la prima query

La prima query consente di raccogliere le consegne collegate a ciascuna campagna. L'obiettivo è quello di visualizzare un rapporto sulle diverse consegne del database Adobe Campaign collegate a ciascuna campagna.
Fate doppio clic sulla prima query per modificarla, quindi applicate i seguenti passaggi per configurarla:
  1. Per iniziare, modificare lo schema a cui viene applicata l'origine della query: selezionare lo Deliveries (nms) schema.
  2. Fare clic sul Edit query collegamento e visualizzare i campi avanzati.
  3. Selezionate i campi seguenti:
    • l'etichetta di consegna,
    • la chiave primaria della consegna,
    • l’etichetta della campagna,
    • l'indicatore delle consegne trasformate,
    • la chiave esterna del collegamento Campaign,
    • l’indicatore del tasso di errore.
    Collegare un alias a ciascun campo: si consiglia di semplificare la selezione dei dati dalla tabella che verrà aggiunta alla prima pagina del rapporto.
    Per questo esempio, verranno utilizzati i seguenti alias:
    • Etichetta: @label
    • Chiave primaria: @deliveryId
    • Etichetta (campagna): @label1
    • Elaborato: @processed
    • Chiave esterna del collegamento 'Campaign' ('id'): @operationId
    • Frequenza errori: @errorRatio
  4. Fate clic due volte sul Next pulsante per passare al Data filtering passaggio.
    Aggiungete una condizione di filtro per raccogliere solo le consegne collegate a una campagna.
    La sintassi di questo filtro è la seguente: "Chiave esterna del collegamento Campagne maggiore di 0".
  5. Fare clic Finish per salvare queste condizioni, quindi fare clic Ok per chiudere l'editor di query.

Passaggio 3: Creare la prima pagina

In questo passaggio, configureremo la prima pagina del rapporto. Per configurarlo, effettua i seguenti passaggi:
  1. Aprite l' Page attività e immettete il relativo titolo, ad esempio Consegne in questo caso.
  2. Inserite un elenco con un gruppo tramite la barra degli strumenti e immettete la relativa etichetta, ad esempio: Elenco di consegne per campagna.
  3. Fate clic sul Table data XPath... collegamento e selezionate il collegamento di consegna, ad es. [query/delivery] .
  4. Fare clic sulla Data scheda e modificare il layout della tabella: aggiungere tre colonne a destra.
  5. Aggiungete un gruppo.
    Questo gruppo consente di raggruppare le campagne e le consegne ad esse collegate.
  6. Nella finestra del gruppo, fate riferimento alla chiave esterna del collegamento "Campagna" e chiudete la finestra.
  7. Modificate la prima cella dell'intestazione del gruppo e inserite il Label campo delle campagne come espressione.
  8. Modificate la seconda cella della riga dei dettagli e selezionate le consegne Label .
  9. Modificate il formato della cella e aprite la Click scheda. Configurate le opzioni adeguate in modo che quando gli utenti fanno clic sul nome di una consegna, questa si apra nella stessa finestra.
    A questo scopo, selezionate un’azione Next page di tipo e In the same window scegliete un’opzione aperta.
  10. Nella sezione inferiore della finestra, fate clic su Add e specificate il /vars/selectedDelivery percorso e l' @deliveryId espressione che corrispondono all'alias della chiave primaria della consegna, come definito nella query creata in precedenza. Questa formula consente di accedere al recapito selezionato.
  11. Modificate la seconda cella della riga piè di pagina del gruppo e immettete Total per campaign come etichetta.
  12. Modificate la terza cella della riga di intestazione del gruppo e immettete Number of messages sent come etichetta.
    Queste informazioni coincidono con il titolo della colonna.
  13. Modificate la terza cella della riga di dettaglio e selezionate come espressione l'indicatore del messaggio elaborato.
  14. Modificate la terza cella della riga piè di pagina del gruppo, selezionate l’indicatore di consegna elaborato e applicate l’ Sum aggregazione.
  15. Modificate la quarta cella della riga di dettaglio e selezionate come espressione il tasso di errore relativo alla distribuzione degli errori.
  16. Selezionare questa cella per visualizzare una barra dei valori che rappresenta la frequenza degli errori di consegna.
    A questo scopo, accedere al formato della cella, quindi passare alla More scheda. Selezionate la Value bar voce nell’elenco a discesa e selezionate l’ Hide the cell value opzione.
    Ora puoi visualizzare un rendering del rapporto. Fate clic sulla Preview scheda e selezionate l’ Global opzione: questo mostra l'elenco di tutte le consegne nel database Adobe Campaign collegate a una campagna.
    È consigliabile utilizzare la Preview scheda per verificare che i dati nella tabella siano selezionati e configurati correttamente. Al termine, è possibile formattare la tabella.
  17. Applica lo Bold stile alle celle che mostrano il totale per campagna e il numero totale di messaggi elaborati.
  18. Fate clic sulla prima cella della riga di intestazione del gruppo, quella in cui è visualizzato il nome della campagna, quindi selezionate Edit > Merge to right .
    L'unione delle prime due celle della riga di intestazione del gruppo riallinea il titolo della campagna e l'elenco delle consegne ad essa collegate.
    È consigliabile attendere la creazione del report prima di unire le celle, poiché l'unione è irreversibile.

Passaggio 4 - Creare la seconda query

Si desidera aggiungere una seconda query e una seconda pagina per visualizzare i dettagli di una consegna quando l'utente del report fa clic su di essa. Prima di aggiungere la query, modificare la pagina creata e abilitare la transizione in uscita in modo che possa essere collegata alla query.
  1. Aggiungete una nuova query dopo l' Page attività e modificatene lo schema: selezionare lo Recipient delivery logs schema.
  2. Modificare la query e definire le colonne di output. Per visualizzare il numero di consegne per dominio e-mail, è necessario:
    • calcola la somma delle chiavi primarie per contare il numero di log di consegna:
    • raccoglie i domini e-mail dei destinatari e le informazioni sui gruppi in questo campo: a tal fine, selezionate l’ Group opzione nella colonna del nome di dominio.
    Collegare i seguenti alias ai campi:
    • count(chiave primaria): @count
    • Dominio e-mail (destinatario): @domain
  3. Fate clic due volte sul Next pulsante: questo ti porta al Data filtering passo.
    Aggiungi una condizione di filtro per raccogliere solo le informazioni collegate alla consegna selezionata.
    La sintassi è la seguente: La chiave esterna del collegamento "Consegna" è uguale al valore dell'impostazione $([vars/selectedDelivery])
  4. Chiudi la finestra di configurazione della query e aggiungi una pagina al grafico, subito dopo la seconda query.

Passaggio 5 - Creare la seconda pagina

  1. Modificate la pagina e immettete la relativa etichetta: Domini e- mail.
  2. Deselezionate l’ Enable output transitions opzione: questa è l'ultima pagina del rapporto e non sarà seguita da un'altra attività.
  3. Aggiungi un nuovo elenco con un gruppo utilizzando il menu di scelta rapida e chiamalo domini e-mail per destinatario .
  4. Fai clic sul Table data XPath... collegamento e seleziona il Recipient delivery logs collegamento.
  5. Nella Data scheda, adattare la tabella come segue:
    • Aggiungete due colonne sul lato destro.
    • Nella prima cella della riga di dettaglio, aggiungere l' rowNum()-1 espressione per contare il numero di righe. Quindi, modificare il formato della cella: nella Extra scheda, selezionare Color tab e fare clic su Ok .
      Questa configurazione consente di utilizzare la tabella come didascalia per il grafico.
    • Nella seconda cella della riga di dettaglio, aggiungere l' Email domain(Recipient) espressione.
    • Nella terza cella della riga di dettaglio, aggiungere l' count(primary key) espressione.
  6. Aggiungi un grafico a torta alla pagina utilizzando il menu di scelta rapida e assegnandogli l’etichetta Domini ​e-mail. Per ulteriori informazioni, fare riferimento ai tipi di grafico e alle varianti .
  7. Fate clic sul Variants collegamento e deselezionate le opzioni Display label e Display caption .
  8. Verificare che non sia configurato alcun ordinamento dei valori. For more on this, refer to this section .
  9. Nella Data scheda, modificare l'origine dati: selezionare Context data dall'elenco a discesa.
  10. Quindi fai clic su Advanced settings e seleziona il collegamento ai registri di distribuzione dei destinatari.
  11. Nella Chart type sezione, selezionare la Email domain variabile.
  12. Aggiungere quindi il calcolo da eseguire: selezionare la somma come operatore.
  13. Fate clic sul Detail pulsante per selezionare il campo che verrà interessato dal conteggio, quindi chiudete la finestra di configurazione.
  14. Salvate il rapporto.
    La pagina è ora configurata.

Passaggio 6 - Visualizzazione del rapporto

Per visualizzare il risultato di questa configurazione, fare clic sulla Preview scheda e selezionare l' Global opzione.
Nella prima pagina del rapporto è riportato l'elenco di tutte le consegne incluse nel database.
Se fai clic sul collegamento di una di queste consegne, viene visualizzato il grafico che mostra la suddivisione dei domini e-mail per la consegna. Ora ti trovi sulla seconda pagina del rapporto e puoi tornare alla pagina precedente facendo clic sul pulsante appropriato.

Creazione di una tabella di suddivisione o pivot

Questo tipo di tabella consente di visualizzare le statistiche calcolate sui dati nel database.
La configurazione di questi tipi di report è simile a quella utilizzata per la procedura guidata di analisi descrittiva. For more on this, refer to this page .
Per ulteriori informazioni sulla creazione di una tabella pivot, consultare questa sezione .