Show Menu
TOPICS×

Note sulla versione 2018

Versioni future, aggiornamenti o modifiche al servizio Experience Cloud Identity per il 2018.

Versione 3.3

Descrizione dell'elemento
Maggiore sicurezza per i cookie AMCV
Durante una scansione della sicurezza interna, è stato rilevato che quando si usa la libreria DTM, i cookie usati per la gestione della sessione non riescono a specificare gli attributi adeguati. Questo potrebbe comportare una condivisione involontaria delle informazioni dei cookie. Per risolvere questo problema è stata introdotta una configurazione che consente al cliente di impostare il cookie AMCV come sicuro. Consulta secureCookie .

Versione 3.2

Descrizione dell'elemento
Maggiore sicurezza per i cookie AMCV
Durante una scansione della sicurezza interna, è stato rilevato che quando si usa la libreria DTM, i cookie usati per la gestione della sessione non riescono a specificare gli attributi adeguati. Questo potrebbe comportare una condivisione involontaria delle informazioni dei cookie. Per risolvere questo problema è stata introdotta una configurazione che consente al cliente di impostare il cookie AMCV come sicuro. Consulta secureCookie.
Il codice di integrazione e l'ID devono essere numeri o stringhe non vuote
È stato corretto un problema di convalida di “setCustomerIDs” quando i dati contengono un codice di integrazione o un ID che non è né un numero né una stringa non vuota.
ECID JS è disponibile nel repository Git pubblico
ECID JS è ora disponibile nel repository Git pubblico per tutti i clienti di Experience Cloud all'indirizzo https://github.com/Adobe-Marketing-Cloud/id-service/releases.

Versione 3.1.2

Descrizione dell'elemento
Picco non realistico nel conteggio di visitatori univoci
Con il rilascio del servizio Experience Cloud Identity 3.1.0, abbiamo riscontrato un problema che causava un picco non realistico nel conteggio dei visitatori univoci in seguito all’implementazione di tale versione. Questo comportamento si verifica solo nell'ultima versione di ECID (3.1.0) e solo se l'utente ha selezionato l'opzione “Consenti solo dal sito Web attuale” nelle impostazioni di privacy del browser Safari. La versione 3.1.2 corregge questo problema.

Versione 3.1.0

È consigliabile passare il prima possibile dalla versione 3.1.0 alla versione più recente. Consultare la descrizione della versione 3.1.2. L’ultimo pacchetto è disponibile da Adobe Experience Platform Launch, DTM e AppMeasurement.
Descrizione dell'elemento
Cookie impostato su un dominio errato
È stato corretto un bug in cui il cookie Visitatore temporaneo impostava un cookie nel dominio del cookie "predefinito" anziché impostarlo nel dominio specificato nella configurazione (initConfig).

Versione 3.0

Descrizione dell'elemento
Thread yielding per richieste di sincronizzazione ID multiple
Iframe
Per i clienti che eseguono più sincronizzazioni di ID, in alcuni casi l'interfaccia utente si blocca a causa dei continui calcoli che la CPU deve elaborare. Stiamo pertanto introducendo la tecnica del thread yielding per separare le richieste di sincronizzazione ID di 100 msec l'una dall'altra.
Questa modifica determinerà un miglioramento delle prestazioni per i clienti che usano Visitor 2.3.0+ e DIL 6.10+.
Possibilità di disattivare le chiamate di terze parti aggiunta
JavaScript - 3.0.0
Adobe ha rinominato le configurazioni seguenti per consentire la disattivazione delle chiamate di sincronizzazione di terze parti.
Da idSyncDisableSyncs a disableIdSyncs
Da idSyncDisable3rdPartySyncing a disableThirdPartyCookies
Supporto per Internet Explorer
Il servizio ID non supporta più Internet Explorer 6, 7, 8 e 9.
Aggiornamento della documentazione getInstance
È stato aggiunto un avviso alla funzione Visitatore per non creare un'istanza di questa funzione con var visitor = new Visitor.