Show Menu
トピック×

order.txtファイルを使用したメニューのカスタマイズ

メニューに関連付けられた order.txt ファイルを編集して、メニューの外観をカスタマイズできます。
この節の手順は、あらゆる種類のメニューで利用できます。
order.txt ファイルを編集してメニューをカスタマイズするには
  1. In the Profile Manager, in the profile name column, right-click the check mark for the order.txt file and click Make Local .
  2. Right-click the check mark for the order.txt file in the User column and click Open > in Notepad . The order.txt file displays.
  3. (Optional) Add or change the # or # setting at the top of the file if desired. This setting controls whether items not listed in the order.txt file but present in the Profile Manager is listed on the menu. 次のオプションがあります。
    • #: ​これがデフォルト設定です。 この設定では、order.txtファイルに指定されていないメニュー項目が、メニューの下部にアルファベット順に表示されます。For example, if theProfile Managercontained a Profile item in addition the those listed in theorder.txtabove, Profile would display below Data.
    • #: ​この設定により、ファイルで指定されていないメニュー項目がメorder.txtニューから除外されます。 For example, if theProfile Managercontained a Profile item in addition the those listed in theorder.txtabove, Profile would not be displayed anywhere on the menu.
    • 空白: ファイルの # 「両端を含む」と「 # します #
  4. 次の手順を実行します。
    実行する作業... 手順...
    メニュー項目の並べ替え
    Data Workbenchに表示する順序で項目名を入力します。
    例えば、各メニュー項目名が対応するファイルまたはフォルダーの名前と一致すれば、次のように指定すると「 テーブル 」が最初に、「 ビジュアライゼーション 」、「 凡例 」、「 注意 」が最後に表示されます。
    テーブル
    ビジュアライゼーション
    凡例
    注意
    メニュー項目の名前の変更
    対応するファイルまたはフォルダーの名前を プロファイルマネージャー で変更して、 order.txt ファイルで項目名を変更します。
    例えば、「注意」を「新規注意」に変更するには、 プロファイルマネージャー で「注意」フォルダーの名前を「新規注意」に変更して、 order.txt ファイルで「注意」項目の名前を「新規注意」に変更します。
    メニュー項目の非表示
    メニュー項目を削除せずに非表示にするには、名前の先頭にマイナス記号(-)を入力します。
    例えば、次のように指定すると、メニューに「 注意 」が表示されなくなります。
    凡例
    -注意
    To again show the hidden menu item, simply remove the minus sign (-) or use the Unhide All parameter in the Insight.cfg file, see Insight Configuration Parameters .
    次の方法でメニュー項目を非表示にすることもできます。
    • .filter .metric または .dim ファイルの Show パラメーターを使用すると、フィルター、派生指標と派生ディメンションおよび拡張ディメンションを各メニューから非表示にできます。このオプションを使用すると、項目はメニューに表示されませんが、プロファイルには存在するので、引き続き使用できます。
      このパラメーターを使用して、フィルター、派生指標および派生ディメンションを非表示にするには、 .metric .dim または .filter ファイルの末尾に次の行を追加します。
      show = bool: false
      このパラメーターを使用して拡張ディメンションを非表示にするには、『 データセット設定ガイド 』の第 10 章で手順を参照してください。
      Insight.cfg ファイルで Unhide All パラメーターを設定して、この方法で非表示にした項目を一時的に表示できます。このパラメーターについて詳しくは、 Insight設定パラメーターを参照してください
    • Transformation.cfg ファイルまたはいずれかのデータセットインクルードファイルの Hidden パラメーターを使用すると、ディメンションメニューから拡張ディメンションを非表示にできます。このオプションを使用すると、項目はメニューに表示されませんが、プロファイルには存在するので、引き続き使用できます。
      注意:この方法を使用して拡張ディメンションを非表示にする場合は、非表示にするディメンションのデータセットを再変換する必要があります。
      Insight.cfg ファイルで Unhide All パラメーターを設定して、この方法で非表示にした項目を一時的に表示できます。このパラメーターについて詳しくは、 Insight設定パラメーターを参照してください
    • 0 バイトのファイルを使用すると、任意のメニューの任意の種類の項目を非表示にできます。このオプションを使用すると、空の(0 バイトの)ファイルによって、データを含む同じ名前のファイルが非表示になります。Data Workbenchは、0バイトのファイルを存在しないかのように扱います。 詳しくは、空の(0バイト)フ ァイルを使用してファイルを非表示にするを参照してください
    メニュー項目の削除
    このファイルが [Exclusive] オプションを使用するように設定されている場合は、このファイルからメニュー項目を削除します。項目自体は引き続きプロファイルに存在しますが、メニューには表示されなくなります。
    このファイルが [Inclusive] オプションを使用するように設定されている場合にメニューから項目を削除するには、このファイルからメニュー項目名を削除したうえで、対応するファイルを削除するか、または 0 バイトにする必要があります。
    ファイルの削除の詳細については、「 作業プロファイルからのファイルの削除 」を参照してください。0バイトファイルについて詳しくは、空の(0バイト)フ ァイルを使用してファイルを非表示にするを参照してください
    グループヘッダーの追加
    表示する見出しのテキストの前と後に、3 つハイフンを入力します。
    例えば、次のように指定すると、一連の関連するメニュー項目に「管理」グループヘッダーを追加できます。
    ---管理---
    プロファイル
    データセット
    メニューのセクションを分離するラインの追加
    ラインを表示する場所に 3 つのハイフンを入力します。
    例えば、次のように指定すると、「注意」と「カスタム」を分離するラインが表示されます。
    注意
    ---
    カスタム
  5. ファイルを保存して閉じます。
  6. (Optional) To make the changes available to all users of the working profile, right-click the white check mark for the order.txt file in the User column and click Save to > * working profile name .