Show Menu
TÓPICOS×

Criação de uma tabela

É possível adicionar uma tabela a um relatório para exibir dados. Pode ser uma tabela dinâmica criada com base em medições de cubo, uma lista com grupo ou uma tabela contendo uma análise de valores.

Criação de uma lista com grupo

Uma tabela do tipo List with group permite agrupar dados na tabela e produzir estatísticas. Por exemplo, é possível criar totais e subtotais para os dados. Cada grupo tem sua própria linha de cabeçalho, detalhe e rodapé.
A atividade Page contendo a tabela deve ser precedida por uma atividade Query ou Script para coletar os dados a serem analisados no relatório. Para obter mais informações sobre essas atividades, consulte Coleta de dados para analisar e atividade de script .

Princípio operacional

Talvez seja necessário analisar várias categorias de dados de uma vez. Uma lista com grupo permite combinar dados e criar estatísticas em vários grupos de dados dentro da mesma tabela. Para fazer isso, é possível criar um grupo na tabela.
No exemplo a seguir, o grupo mostra todas as campanhas no banco de dados, os deliveries e o número de mensagens enviadas por delivery e por campanha.
Isso permite listar as campanhas ( Label (Campaign) , a lista de deliveries ( Label ) vinculada à campanha e permite contar o número de mensagens enviadas por delivery ( Processed) , antes de adicioná-las a cada campanha ( Sum(@processed) ).

Etapas de implementação

Um exemplo completo de implementação é fornecido aqui: Caso de uso: crie um relatório com uma lista de grupos .
Observe as seguintes etapas para criar uma tabela do tipo "Lista com grupo":
  1. Ir para o gráfico de relatório e inserir uma atividade Query . Consulte Coleta de dados para analisar .
  2. Preencha a tabela de origem e selecione os campos da tabela que as estatísticas abordarão.
  3. Coloque uma atividade Page no gráfico. Para obter mais informações, consulte Elementos estáticos .
  4. Insira uma tabela do tipo List with group na página.
  5. Especifique o caminho de dados ou a tabela selecionada como uma fonte de dados na query.
    Essa etapa é obrigatória se desejar recuperar os campos na tabela de origem posteriormente e inseri-los nas células da tabela.
  6. Criação da tabela e seu conteúdo
  7. Exiba o relatório finalizado na guia Preview . É possível então publicar o relatório e exportá-lo em um formato diferente se necessário. Para obter mais informações, consulte Exportação de um relatório .

Adição de linhas e colunas

Por padrão, uma tabela do tipo List with group inclui uma linha de cabeçalho, detalhe e rodapé.
O próprio grupo inclui linhas de cabeçalho, detalhe e rodapé.
  • Linha de cabeçalho : esta linha permite fornecer um título para as colunas da tabela.
  • Linha de detalhe : esta linha contém valores de estatística.
  • Linha de rodapé : esta linha permite exibir os valores totais.
Linhas e colunas podem ser adicionadas para satisfazer qualquer necessidade.
O grupo pode ser colocado em qualquer linha da tabela e inclui sua própria linha de cabeçalho, detalhe e rodapé.
Linha e coluna : para adicionar ou excluir uma linha ou coluna, vá para uma linha ou coluna existente e use o menu do botão direito do mouse.
A natureza da linha que adicionar depende do local do cursor. Por exemplo, para adicionar uma linha de cabeçalho, coloque o cursor em um cabeçalho e clique em Add > A line above/below .
A largura das colunas pode ser modificada por meio do item Column format .
Grupo : para adicionar um grupo, vá para uma linha e selecione o item correspondente no menu suspenso.

Definição do conteúdo da célula

Para editar uma célula da tabela e definir seu conteúdo e formato, vá para a célula e use o menu do botão direito do mouse.
Use a entrada do menu Expression para selecionar os valores a serem exibidos.
  • Para inserir os valores a serem analisados diretamente na tabela, selecione-os entre os campos disponíveis.
    A lista de campos disponíveis coincide com o conteúdo da query antes da tabela no gráfico de criação de relatório.
  • Insira um rótulo para uma célula, o cabeçalho um, por exemplo.
    Para fazer isso, use o mesmo processo de inserção de um campo no banco de dados, mas não selecione uma expressão. Insira o rótulo no campo Label . Ele será exibido como está.
  • Cálculo de uma agregação (uma média, uma soma, etc.) e sua exibição na célula
    Para fazer isso, use a entrada de menu Aggregates e selecione a campanha desejada.

Definição do formato de célula

Para definir o formato da célula, o menu Cell format... permite acessar todas as opções de formatação disponíveis para a célula selecionada.
Essas opções permitem personalizar a renderização final do relatório e facilitar a leitura das informações.
Use o campo Carriage return ao exportar dados para o Excel: selecione o valor Yes para forçar o retorno. Esse valor será mantido ao exportar. Para obter mais informações, consulte Exportação de um relatório .
A janela Cell format permite acessar a seguinte guia:
  • A guia Value
  • A guia Borders
  • A guia Click
  • A guia Extra
A guia Value permite alterar a fonte e os vários atributos de valor ou definir um formato com base em sua natureza.
O formato altera a exibição de dados: por exemplo, os formatos Number , Monetary e Percentage permitem alinhar os números à direita e exibir pontos decimais.
Exemplo de como configurar um formato de moeda: é possível especificar a moeda em que os valores são expressos, escolher separar milhares e mostrar valores negativos em vermelho. A posição do símbolo de moeda depende do idioma do operador definido em seu perfil.
Exemplo de configuração para datas: é possível escolher se deseja ou não exibir o tempo.
A guia Bordas permite adicionar bordas às linhas e colunas na tabela. A adição de bordas às células pode levar a problemas de desempenho ao exportar relatórios grandes para o Excel.
Se necessário, é possível definir bordas no modelo da tabela ( Administration > Configuration > Form rendering ).
Nesse caso, haverá a seguinte sintaxe:
Na guia Web:
 .tabular td {
 border: solid 1px #000000;
 }

Na guia Excel:
 <style name="odd" fillColor="#fdfdfd">
  <border>
   <borderTop value="solid 0.05pt #000000" />
   <borderBottom value="solid 0.05pt #000000" />
   <borderLeft value="solid 0.05pt #000000" />
   <borderRight value="solid 0.05pt #000000" />
  </border>
 </style> 
 
 <style name="even" fillColor="#f7f8fa">
  <border>
   <borderTop value="solid 0.05pt #000000" />
   <borderBottom value="solid 0.05pt #000000" />
   <borderLeft value="solid 0.05pt #000000" />
   <borderRight value="solid 0.05pt #000000" />
  </border>
 </style> 

A guia Click permite definir uma ação quando o usuário clicar no conteúdo de uma célula ou da tabela.
No exemplo abaixo, clicar no valor na célula permite exibir a segunda página do relatório: ela conterá informações sobre o delivery na célula.
A guia Extra permite vincular um visual a seus dados, como uma marca colorida ou uma barra de valores. A marca colorida é usada quando a tabela é mostrada como uma legenda em um gráfico. Para obter mais informações, consulte o exemplo de implementação: Etapa 5 - Criar a segunda página

Caso de uso: criar um relatório com uma lista de grupos

Neste exemplo, vamos criar um relatório de duas páginas: a primeira página conterá a lista e os deliveries totais por campanha, bem como o número de mensagens enviadas. Os nomes dos deliveries serão links clicáveis e permitirão ir para a segunda página do relatório para exibir a análise dos deliveries por domínio de email para o delivery selecionado com uma tabela e um gráfico. Na segunda página, a tabela servirá como uma legenda para o gráfico.

Etapa 1 - Criar um relatório

Crie um novo relatório que atenda ao schema da campanha, Campaigns (nms) .
Clique em Save para criar o relatório.
Vá para o gráfico e adicione os primeiros componentes a serem usados para criar o conteúdo do relatório: uma primeira query e uma primeira página.

Etapa 2 – Criar a primeira query

A primeira query permite coletar os deliveries vinculados a cada campanha. O objetivo é exibir um relatório sobre os vários deliveries do banco de dados do Adobe Campaign vinculados a cada campanha.
Clique duas vezes na primeira query para editá-la e siga as etapas abaixo para configurá-la:
  1. Comece alterando o schema no qual a origem da consulta é aplicada: selecione o schema Deliveries (nms) .
  2. Clique no link Edit query e exiba os campos avançados.
  3. Selecione os seguintes campos:
    • o rótulo do delivery,
    • a chave primária do delivery,
    • o rótulo da campanha,
    • o indicador dos deliveries processados,
    • a chave externa do link Campaign,
    • o indicador de taxa de erro.
    Vincular um alias a cada campo: é recomendável para facilitar a seleção de dados da tabela que será adicionada à primeira página do relatório.
    Neste exemplo, usaremos os seguintes aliases:
    • Rótulo: @label
    • Chave primária: @deliveryId
    • Rótulo (Campaign): @label1
    • Processado: @processed
    • Chave externa do link "Campaign" (campo "id"): @operationId
    • Taxa de erro: @errorRatio
  4. Clique no botão Next duas vezes para chegar à etapa Data filtering .
    Adicione uma condição de filtragem para coletar apenas os deliveries vinculados a uma campanha.
    A sintaxe desse filtro é a seguinte: "Foreign key of the 'Campaigns' link greater than 0".
  5. Clique em Finish para salvar essas condições e em Ok para fechar o editor da consulta.

Etapa 3: criação da primeira página

Nesta etapa, vamos configurar a primeira página do relatório. Para configurá-la, siga as etapas abaixo:
  1. Abra a atividade Page e insira seu título, por exemplo Deliveries neste caso.
  2. Insira uma lista com um grupo na barra de ferramentas e insira o rótulo, por exemplo: lista de deliveries por campanha.
  3. Clique no link Table data XPath... e selecione o link de delivery, ou seja, [query/delivery]
  4. Clique na guia Data e altere o layout da tabela: adicione três colunas à direita.
  5. Adicione um grupo.
    Este grupo permitirá agrupar campanhas e os deliveries vinculadas a elas.
  6. Na janela do grupo, faça referência à chave externa do link "Campaign" e feche a janela.
  7. Edite a primeira célula do cabeçalho do grupo e insira o campo Label das campanhas como uma expressão.
  8. Edite a segunda célula da linha de detalhes e selecione os deliveries Label .
  9. Edite o formato dessa célula e abra a guia Click . Configure as opções adequadas para que, quando os usuários clicarem no nome de um delivery, ele seja aberto na mesma janela.
    Para fazer isso, selecione uma ação do tipo Next page e selecione In the same window como uma opção para abrir.
  10. Na seção inferior da janela, clique em Add e especifique o /vars/selectedDelivery caminho e a expressão @deliveryId que corresponde ao alias da chave primária do delivery, conforme definido na consulta criada anteriormente. Essa fórmula permite acessar o delivery selecionado.
  11. Edite a segunda célula do rodapé do grupo e digite Total per campaign como rótulo.
  12. Edite a terceira célula da linha de cabeçalho do grupo e digite Number of messages sent como rótulo.
    Essas informações coincidem com o título da coluna.
  13. Edite a terceira célula da linha de detalhes e selecione o indicador de mensagem processada como uma expressão.
  14. Edite a terceira célula do rodapé do grupo, selecione o indicador de entrega processado e aplique a agregação Sum a ele.
  15. Edite a quarta célula da linha de detalhes e selecione error delivery error rate como uma expressão.
  16. Selecione essa célula para exibir uma barra de valores que representa a taxa de erro de delivery.
    Para fazer isso, acesse o formato da célula e vá para a guia More . Selecione a entrada Value bar na lista suspensa e selecione a opção Hide the cell value .
    Agora é possível exibir uma renderização do relatório. Clique na guia Preview e selecione a opção Global : isso mostra a lista de todos os deliveries no banco de dados do Adobe Campaign que estão vinculados a uma campanha.
    Recomendamos o uso da guia Preview para garantir que os dados na tabela sejam selecionados e configurados corretamente. Assim que isso for feito, é possível formatar a tabela.
  17. Aplique o estilo Bold às células que mostram o total por campanha e o número total de mensagens processadas.
  18. Clique na primeira célula da linha de cabeçalho do grupo, aquela que exibe o nome da campanha e selecione Edit > Merge to right .
    Mesclar as duas primeiras células da linha de cabeçalho do grupo realinha o título da campanha e a lista de deliveries vinculadas a ela.
    Recomendamos aguardar até que o relatório seja criado antes de mesclar células já que a mescla é irreversível.

Etapa 4 – Criação da segunda query

Queremos adicionar uma segunda query e uma segunda página para exibir o detalhe de um delivery quando o usuário do relatório clicar nele. Antes de adicionar a query, edite a página criada e habilite a transição de saída para que ela possa ser vinculada à query.
  1. Adicione uma nova consulta após a atividade Page e edite o schema: selecione o schema Recipient delivery logs .
  2. Edite a query e defina as colunas de saída. Para exibir o número de fornecimentos por domínio de email, é preciso:
    • calcular a soma das chaves primárias para contar o número de logs do delivery:
    • coletar domínios de email dos recipients e informações do grupo neste campo: para fazer isso, selecione a opção Group na coluna de nome de domínio.
    Vincule os seguintes aliases aos campos:
    • contagem (chave primária): @count
    • Domínio de email (recipient): @domain
  3. Clique duas vezes no botão Next : isso leva à etapa Data filtering .
    Adicione uma condição de filtro para coletar apenas as informações vinculadas ao delivery selecionado.
    A sintaxe é a seguinte: a chave estrangeira do link "Delivery" é igual ao valor da configuração $([vars/selectedDelivery])
  4. Feche a janela de configuração de query e adicione uma página ao gráfico, logo após a segunda query.

Etapa 5 – Criação da segunda página

  1. Edite a página e insira o rótulo: Email domains .
  2. Desmarque a opção Enable output transitions : essa é a última página do relatório e não será seguida por outra atividade.
  3. Adicione uma nova lista com um grupo usando o menu do botão direito do mouse e rotule de Email domains per recipient .
  4. Clique em Table data XPath... e selecione o link Recipient delivery logs .
  5. Na guia Data , adapte a tabela como a seguir:
    • Adicione duas colunas ao lado direito.
    • Na primeira célula da linha de detalhes, adicione a expressão rowNum()-1 para contar o número de linhas. Em seguida, altere o formato da célula: na guia Extra , selecione Color tab e clique em Ok .
      Essa configuração permitirá usar a tabela como legenda do gráfico.
    • Na segunda célula da linha de detalhes, adicione a expressão Email domain(Recipient) .
    • Na terceira célula da linha de detalhes, adicione a expressão count(primary key) .
  6. Adicione um gráfico de pizza à página usando o menu do botão direito e atribua o rótulo Email domains a ele. Para obter mais informações, consulte Tipos e variantes de gráfico .
  7. Clique no link Variants e desmarque as opções Display label e Display caption .
  8. Verifique se nenhuma classificação de valor está configurada. Para obter mais informações, consulte esta seção .
  9. Na guia Data , altere a fonte de dados: selecione Context data na lista suspensa.
  10. Em seguida, clique em Advanced settings e selecione o link para os logs do delivery do recipient.
  11. Na seção Chart type , selecione a variável Email domain .
  12. Em seguida, adicione o cálculo a ser executado: selecione a soma como um operador.
  13. Clique no botão Detail para selecionar o campo que a contagem utilizará, então feche a janela de configuração.
  14. Salve o relatório.
    A página está configurada agora.

Etapa 6 - Exibição do relatório

Para exibir o resultado dessa configuração, clique na guia Preview e selecione a opção Global .
A primeira página do relatório detalha a lista de todos os deliveries incluídos no banco de dados.
Se clicar no link de um desses deliveries, ele mostrará o gráfico com a análise dos domínios de email para esse delivery. Agora, essa é a segunda página do relatório e é possível retornar à página anterior clicando no botão apropriado.

Criação de uma análise ou tabela dinâmica

Esse tipo de tabela permite exibir estatísticas calculadas dos dados do banco de dados.
A configuração desses tipos de relatórios é semelhante à utilizada para o assistente de análise descritiva. Para obter mais informações, consulte esta página .
Para obter mais informações sobre criação de uma tabela dinâmica, consulte esta seção .