Show Menu
TÓPICOS×

Pacote de compatibilidade

Visão geral

A comunicação interativa é a abordagem padrão e recomendada para criar comunicações com o cliente no AEM Forms 6.5. Para continuar usando letras no AEM Forms 6.5, é necessário instalar o pacote de compatibilidade do AEMFD mais recente.
O pacote Compatibilidade do AEMFD também permite usar os seguintes ativos do AEM Forms 6.4, 6.3 e 6.2 no AEM Forms 6.5:
  • Fragmentos de documento
  • Cartas
  • Dicionários de dados
  • Formulários adaptáveis modelos e páginas obsoletos
Para obter mais informações, consulte Ativos compatíveis com o AEM Forms 6.5 instalando o pacote Compatibilidade.

Adicionar suporte para ativos AEM Forms 6.4, 6.3 e 6.2 no AEM Forms 6.5

Após executar uma atualização, faça o seguinte para instalar o pacote de compatibilidade do AEMFD e tornar seus ativos compatíveis com o 6.5:
Verifique se você tem o pacote de compatibilidade AEM pré-instalado.
  1. Instale o pacote de compatibilidade 6.5 mais recente.
    Para obter mais informações sobre como carregar e instalar o pacote, consulte Como trabalhar com pacotes .
  2. Após a estabilização dos registros, reinicie o servidor.
  3. Use o utilitário de migração para tornar seus ativos compatíveis com a versão 6.5.
    Para obter mais informações, consulte Utilitário de migração.

Ativos compatíveis com o AEM Forms 6.5 ao instalar o pacote de compatibilidade

Ao instalar o pacote de compatibilidade, você pode tornar os seguintes ativos e modelos compatíveis com o AEM Forms 6.5:
  • Ativos de gerenciamento de correspondência do AEM 6.4 e anteriores:
  • Modelos obsoletos de formulário adaptativo:
    • /libs/fd/af/models/blankTemplate2
    • /libs/fd/af/models/simpleEnrollmentTemplate
    • /libs/fd/af/models/simpleEnrollmentTemplate2
    • /libs/fd/af/models/surveyTemplate
    • /libs/fd/af/models/surveyTemplate2
    • /libs/fd/af/models/tabbedEnrollmentTemplate
    • /libs/fd/af/models/tabbedEnrollmentTemplate2
    • /libs/fd/afaddon/models/advancedEnrollmentTemplate
    • /libs/fd/afaddon/models/advancedEnrollmentTemplate2
  • Páginas obsoletas para formulários adaptativos:
    • /libs/fd/af/components/page/survey
    • /libs/fd/af/components/page/tabbedenrollment
    • /libs/fd/afaddon/components/page/advancedenrollment