Show Menu
主题×

已弃用和已删除的功能

Adobe不断评估产品功能,以确定应用更现代的替代方案替换的旧功能,以提高整体客户价值,始终要仔细考虑向后兼容性。 由于Adobe Campaign经典可与第三方工具一起使用,因此会定期更新兼容性,以便仅实施受支持的版本。 下面列出了与Adobe Campaign经典不再兼容的版本。
要传达即将拆除/替换Campaign Classic功能,请应用以下规则:
  • 首先宣布弃用。 尽管已弃用的功能仍可供现有用户使用,但不会进一步增强或记录这些功能。
  • 在以下版本中最早将删除已弃用的功能。 本页会宣布实际的删除目标日期。
此过程为客户提供了至少一个发布周期,以在实际删除之前,使其实施适应已弃用功能的新版本或后继版本。
Adobe Campaign版本和新功能列在发 行说明中

Deprecated features

本节介绍最新列表版本中标记为已弃用的Campaign Classic特性和功能。
通常,计划在未来版本中删除的功能会首先设置为已弃用,并提供替代功能。 这些特性和功能不再适用于新Campaign Classic客户,也不应用于任何新实施。 它们也会从产品文档中删除。
建议客户检查他们是否在当前部署中利用了功能/功能,并制定计划更改其实施以使用所提供的替代方案。 请参阅目标删除日期,以相应地规划环境和项目更新。

Adobe Campaign18.6版本

区域 功能 替换
Javascript SDK安全性   decryptString  
出于安全原 ,对于新安装,decryptString API在默认情况下不再可用。
在指向18.6(及更高版本)的上下文中,此API不再激活,已由decryptPassword函数 替换
 

Adobe Campaign18.4版本

区域 功能 替换
电子邮件存档   基于文件的归档  
电子邮件存档现在可通过专用的密送电子邮件地址进行。 了解更多
目标删除日期: 活动20.2版本- 2020年6月
 
潜在客户管理   潜在客户  
Adobe Campaign经典中的Leads管理包简化了构建和维护整个Lead管理生命周期的过程。 类似的功能可以通过其他本机工作流活动和数据模型修改来实现。
目标删除日期: 活动20.2版本- 2020年6月
 

已弃用的兼容性

Adobe Campaign20.1版本

从2月20.1版开始,已弃用以下系统进行Campaign Classic。 兼容性将在20.2版本中终止- 2020年6月。
区域 替换
Campaign Classic客户端控制台32位  
Campaign Classic客户端控制台64位
 

Adobe Campaign19.2版

从19.2秋季版本开始,下列操作系统已弃用于Campaign Classic。 兼容性将于2020年结束。
请参阅兼容性 ,以升级到较新版本或迁移到新系统。

删除的功能

本节列表已从Campaign Classic中删除的特性和功能。
区域——功能 替换 版本
活动API文档- jsapi.chm文件   Campaign ClassicAPI现在可在专用页面中使用。 如果您使用的是jsapi.chm文件,您现在应该参 考新的联机版本 19.1
活动编排——预测营销 Adobe Campaign经典中预测营销功能的很大一部分是预测模型的消耗。 尽管预测营销工作流活动将在即将发布的版本中删除,但Adobe Campaign将继续支持通过其他工作流活动消耗和使用来自外部源的预测模型。 18.10
Web 应用程序-微型站点 通过限制仅访问Adobe Campaign配置文件上的专用域来提高安全性。 您仍可以使用DNS别名在活动中使用个性化URL。 了解更多 18.10
推送通知- iOS二进制连接器   根据Apple的建议,Adobe将删除旧版iOS二进制连接器。 功能更强、效率更高的基于HTTP/2的连接器现已可用。 18.10
移动渠道- MMS和WAP推送消息 不再提供MMS和Wap推送渠道。 作为替代,您可以利 用SMS 推送 投放。 18.4
移动渠道- LINE v1 LINE Connect包不再可用于在Adobe Campaign经典中安装。 Adobe建议使用新的LINE渠道包发送LINE消息。 了解更多 18.4

兼容性终止

Adobe Campaign经典与兼容性矩阵中列出的所有系统和工 具兼容 。 当这些第三方系统和工具的特定版本与其各自的创建者达到生命周期终止(EOL)时,Adobe Campaign不再与这些版本兼容: 它们被宣布为已弃用,然后从后续产品发行版的兼容性矩阵中删除。 请确保您使用兼容性矩阵中列出的任何系统的受支持版本,以避免出现任何问题。

客户端控制台

Adobe Campaign经典客户端控制台无法再在以下系统上运行,因为其编辑器已弃用它们。 在其中某个版本上运行活动客户端控制台的客户需要在目标删除日期之前升级到最新版本。 请参阅兼容性
  • Windows Server 2003、2008、2008 R2
  • Windows XP、Vista

操作系统

从19.1版本开始,Adobe Campaign不再与以下操作系统兼容。

Web服务器

从19.1 Spring Release开始,Adobe Campaign不再与以下Web服务器兼容。

工具

从19.1 Spring发行版开始,Adobe Campaign不再与以下工具兼容。

数据库引擎

Adobe不支持以下数据库引擎,因为其编辑器已弃用它们。 在这些版本中运行的客户需要升级到最新版本或迁移到另一个版本。
请参阅 Campaign Classic兼容性表 ,访问兼容版本的列表。
联合数据访问(联合数据访问)
从19.1 Spring发行版开始,Adobe Campaign不再与以下联合数据访问服务器兼容。
Campaign Classic与联合数据访问(联合数据访问)下的服务器不兼容。
  • DB2 UDB 9.5、9.7。支持更新版本的DB2,通过联合数据访问(联合数据访问)。 了解更多
  • Oracle 9i、10G R2。 支持更新版本的Oracle,联合数据访问(联合数据访问)。 了解更多
  • PostgreSQL 8.3、8.4、9.0、9.1、9.2。支持更新版本的PostgreSQL通过联合数据访问(联合数据访问)。 了解更多
  • MSSQL 2000、2005、2008 R2。 支持更新版本的SQL Server,方法是联合数据访问(联合数据访问)。 了解更多
  • MySQL 5.1。支持更新版本的MySQL通过联合数据访问(联合数据访问)。 了解更多
  • InfiniDB已经寿终正寝。 了解更多
  • Teradata 13、13.1。通过联合数据访问(联合数据访问)支持更新版本的Teradata。 了解更多
  • 内泰扎6.02,7.0。 了解更多
  • AsterData 5.0。 AsterData已经寿终正寝。 了解更多
  • Sybase IQ 15.2、15.4、15.5和Sybase ASE 15.0。支持更新版本的Sybase通过联合数据访问(联合数据访问)。 了解更多
  • 通过HiveSQL的Hadoop: Hadoop 2.7.3、HiveSQL 1.2.1。Adobe Campaign经典仍通过联合数据访问(联合数据访问)通过HiveSQL支持列出的Hadoop版本,但这些版本与以下版本合并: HortonWorks(HDP 2.4.X、2.5.x、2.6.x)和HDInsight 3.4(HDP 2.4)、3.5(HDP 2.5)、3.6(HDP 2.6)
RDBMS服务器
Adobe Campaign与以下RDBMS服务器不兼容:
  • Oracle 10GR2、11G
  • PostgreSQL 9.0到9.3
  • SQL Server 2005
  • MySQL 5.1
  • DB2 UDB 9.7