Technical Requirements

You are reading the AEM 6.2 version of Technical Requirements.
This documentation is also available for the following versions:  AEM 6.3  AEM 6.1  AEM 6.0  AEM 5.6.1  AEM 5.6  CQ 5.5  CQ 5.4 

Adobe supports Adobe Experience Manager (AEM) on the platforms as detailed in the following information in this document.

For any issues that are specifically related to the platform itself, you will need to contact the platform vendor directly.

Note

Depending upon the platform on which you install AEM, there could be different sets of requirements for user management.

Prerequisites

To install Adobe Experience Manager you need at a minimum:

  • Installed Java Platform, Standard Edition JDK - or other supported Java Virtual Machines
  • Experience Manager Quickstart file (Standalone JAR or web-application deployment WAR)

Minimum Sizing Requirements

The following are the minimum requirements:

  • 5 GB free disk space in the installation directory
  • 2 GB memory

Note

Digital asset use cases need more base memory. See Deploying and Maintaining for details.

You will have to increase these in accordance with your operational expectations. Please see the Hardware Sizing Guidelines for further information.

Support Levels

This document lists the supported client and server platforms for Adobe Experience Manager. Adobe provides several levels of support, both for our recommended configurations and for other configurations.

Recommended Configurations

Adobe recommends these configurations and provides full support as part of the standard software maintenance agreement.

Support Level Description
A: Supported Adobe provides full support and maintenance for this configuration. This configuration is covered by Adobe's quality assurance process.
R: Restricted Support To ensure our customers project success, Adobe provides full support within a restricted support program, which requires that specific conditions are met. R-level support requires a formal customer request and confirmation by Adobe. For more informations, please contact Adobe Customer Care.

Unsupported Configurations

Support Level Description
E: Expected to work The configuration is expected to work, and there are no reports to the contrary.
Z: Not supported The configuration is not supported. Adobe does not make any statements about whether the configuration works, and does not support it.

Supported Platforms

Java Virtual Machines

The application requires a Java Virtual Machine to run, which is provided by the Java Development Kit (JDK) distribution.

Adobe Experience Manager operates with the following versions of the Java Virtual Machines:

Caution

It is recommend to track the Security Bulletins from the Java vendor to ensure the safety and security of production environments and install the latest Java Updates.

Platform Support Level
Oracle SE 8 JDK 1.8.x (64bit) A: Supported
Oracle SE 7 JDK 1.7.x (64bit) Z: Not supported
IBM J9 VM (build 2.8, JRE 1.8.0) Z: Not supported
IBM J9 VM (build 2.6 & 2.7, JRE 1.7.0) A: Supported
IBM J9 VM (build 2.4 & 2.6, JRE 1.6.0) Z: Not supported
HP JDK 8.0.x A: Supported
HP JDK 7.0.x Z: Not supported
  • The IBM JRE is only supported on IBM server platforms (AIX), or in conjunction with WebSphere Application Server.
  • The HP JRE is only supported on HP server platforms (HP-UX).

Storage & Persistence

There are various options to deploy the repository of Adobe Experience Manager. Following a list of supported technologies and storage options.

Platform Description Support Level
File System (1) Repository Microkernel (TAR files) A: Supported
File System (1) To store binaries A: Supported
MongoDB Enterprise 2.6 (2) Repository Microkernel
Z: Not supported
MongoDB Enterprise 3.0 (2)(3) Repository Microkernel A: Supported
MongoDB Enterprise 3.2 (2)(3) Repository Microkernel A: Supported
IBM DB2 10.5  Repository Microkernel R: Restricted Support
Oracle Database 12c Repository Microkernel R: Restricted Support
Microsoft SQL Server 2012 (4) Repository Microkernel R: Restricted Support
Amazon S3 To store binaries A: Supported
Apache Solr To use as internal search engine A: Supported
  1. 'File System' includes block storage that is POSIX compliant. This includes network storage technology. Mind that file system performance might vary and influences the overall performance. It is recommended to load test AEM in combination with the network/remote file system.
  2. MongoDB Sharding is not supported in AEM.
  3. MongoDB Storage Engine WiredTiger is supported only.

 

Note

See Deploying Communities for additional information regarding the AEM Communities capability.

Note

MongoDB is third-party software and is not included in the AEM licensing package. For more information see the MongoDB licensing policy page.

In order to get the most of your AEM deployment, Adobe recommends licensing the MongoDB Enterprise version in order to benefit from professional support. See Recommended Deployments for more information.

The license includes a standard replica set, which is composed of one primary and two secondary instances that can be used for either the author or the publish deployments.

In case you wish to run both author and publish on MongoDB, two separate licenses need to be purchased.

Adobe Customer Care will assist qualifying issues related to the usage of MongoDB with AEM.

For more information, see the MongoDB for Adobe Experience Manager page.

Note

Supported relational databases as listed above is third-party software and is not included in the AEM licensing package. 

In order to run AEM 6.2 with a supported relational database, it is required that you have a separate support contract with a database vendor directly. Adobe Customer Care will assist qualifying issues related to the usage of relational databases with AEM 6.2.

Please note, that all relational databases are currently supported within Level-R on AEM 6.2, which comes with support criterias and a support program as stated in the Level-R description above.

Servlet Engines / Application Servers

Adobe Experience Manager can run either as a standalone server (the quickstart JAR file) as web application within a third party application server (the WAR file).

Minimum Servlet API Version required: 3.0

Platform Support Level
Quickstart built-in Servlet Engine (Jetty 9.2) A: Supported
Oracle WebLogic Server 12.2 (12cR2) A: Supported
Oracle WebLogic Server 12.1.3 (12c) A: Supported
Oracle WebLogic Server 10.3.6 (11g) Z: Not supported
IBM WebSphere Application Server 9 Z: Not supported
IBM WebSphere Application Server 8.5.5 A: Supported
IBM WebSphere Application Server 8.5.5 Liberty Profile A: Supported
IBM WebSphere Application Server 8.5 A: Supported
IBM WebSphere Application Server 8 Z: Not supported
IBM WebSphere Application Server 7 Z: Not supported
Apache Tomcat 8 A: Supported (2)
Apache Tomcat 7 Z: Not supported
Apache Tomcat 6 Z: Not supported
JBoss EAP 7.0.0 with JBoss Application Server Z: Not supported
JBoss EAP 6.4.0 with JBoss Application Server 7.5 A: Supported
JBoss EAP 6.3.0 with JBoss Application Server 7.4 A: Supported
JBoss EAP 6.2.0 with JBoss Application Server 7.3 Z: Not supported
JBoss EAP 6.1.0 with JBoss Application Server 7.2
Z: Not supported
JBoss Application Server 7.1 Z: Not supported

Server Operating Systems

Adobe Experience Manager works with the following server platforms:

Platform Support Level
Microsoft Windows Server 2016 Z: Not supported
Microsoft Windows Server 2012 R2 A: Supported
Microsoft Windows Server 2012 A: Supported
Microsoft Windows Server 2008 R2 Z: Not supported
Microsoft Windows Server 2008 Z: Not supported
Oracle Solaris 11 A: Supported with limitations (3,5)
Oracle Solaris 10 A: Supported with limitations (3,5)
RedHat Linux Kernel 2.6 and 3.x Distributions (1) A: Supported
Debian Distribution incl. Ubuntu 14 A: Supported
HP-UX 11i v1-3 A: Supported with limitations (2,3,4,5)
IBM AIX 7.1 A: Supported with limitations (2,3,5)
IBM AIX 6.1 Z: Not supported
SUSE Linux Enterprise Server 12 A: Supported
SUSE Linux Enterprise Server 11 Z: Not supported
Apple OS X Server E: Expected to work (6)
  1. Linux Kernel 2.6 and 3.x includes derivatives from Red Hat distribution, including Red Hat Enterprise Linux, CentOS, Oracle Linux and Amazon Linux.
  2. Please see the section Support for XMP metadata write-back
  3. No support for Dynamic Media Imaging. Dynamic Media Video is supported.
  4. No support for XFA based adaptive forms, XFA to PDF and/or HTML conversion (Experience Manager Forms), and AEM Forms add-on features.
  5. No support for Advanced Raw file transformation (Experience Manager Assets)
  6. Not supported in production environment for AEM Forms.

Virtual & Cloud Computing Environments

Adobe Experience Manager running in virtual machines in the cloud computing environments is supported in compliance with Adobe's support policy for all other system components (operating system, JVM, application server, etc).

Experience Manager works with virtual machines in the following cloud computing environments, similar to the deployment on other virtual servers or dedicated servers:

  • Amazon EC2
  • Rackspace Cloud
  • VMware vCloud

Dispatcher Platforms (Web Servers)

The Dispatcher is the caching and load balancing component. Download the latest Dispatcher version from Adobe PackageShare. Experience Manager 6.2 requires Dispatcher version 4.1.12 or higher.

The following web servers are supported for use with a Dispatcher version 4.1.12:

Platform Support Level
Apache httpd 2.4.x A: Supported (1)
Apache httpd 2.2 A: Supported (1)
Apache httpd 2.0 Z: Not Supported
Microsoft IIS 10 (Internet Information Server) Z: Not Supported
Microsoft IIS 8.5 (Internet Information Server) A: Supported
Microsoft IIS 8.0 (Internet Information Server) A: Supported
Microsoft IIS 7.5 (Internet Information Server) Z: Not Supported
Microsoft IIS 7 (Internet Information Server) Z: Not Supported
Oracle iPlanet Web Server 7 A: Supported

(1) Web servers built on the basis of Apache httpd source code will have the same level of support as the version of httpd on which it is based only in the following cases:

  • The HTTP server was built using only official Apache source distributions, or
  • The HTTP server was delivered as part of the operating system on which it is running.

Examples: IBM HTTP Server, Oracle HTTP Server

If in doubt, please ask Adobe for confirmation of the support level related to the respective server product.

Dispatcher is not available for Apache 2.4.x for Windows operating systems.

Supported Client Platforms

Supported Browsers for Authoring User Interface

The Adobe Experience Manager user interface works with the following client platforms. All browsers are tested with the default set of plug-ins and add-ons.

The user interface is optimized to be used on larger screens (typically notebooks and desktop computers) and tablet form factor (such as Apple iPad or Microsoft Surface). The phone form factor is not supported.

Note

Support for browsers with rapid release cycles:

Mozilla Firefox, Google Chrome and Microsoft Edge release updates every few months. Adobe is committed to provide updates for Adobe Experience Manager to maintain the support level as stated below with upcoming versions of these browsers.

Browser Support for Classic UI
Support for Touch-optimized UI
Microsoft Edge (1) A: Supported A: Supported
Microsoft Internet Explorer 11 (1) A: Supported A: Supported
Microsoft Internet Explorer 10 Z: Not supported Z: Not supported
Microsoft Internet Explorer 9 (2) A: Supported Z: Not supported
Microsoft Internet Explorer 8 Z: Not supported Z: Not supported
Mozilla Firefox 50+ A: Supported A: Supported
Mozilla Firefox 45 (ESR) (3) A: Supported A: Supported
Google Chrome 55+ A: Supported A: Supported
Apple Safari 10 (macOS) A: Supported A: Supported
Apple Safari 9 (OS X) A: Supported A: Supported
Apple Safari 8 (OS X) A: Supported A: Supported
Apple Safari on iOS 10 (1,4) Z: Not supported Z: Not supported
Apple Safari on iOS 9 (1,4) Z: Not supported A: Supported
  • (1) AEM Forms does not support authoring on mobile devices.
  • (2) Not supported for AEM Forms
  • (3) Extended Support Release of Firefox Learn more about this on mozilla.org
  • (4) support for Apple iPad and Apple iPad mini

Note

Microsoft Internet Explorer 9 is not supported for the user administration interface of AEM, including Adobe’s identity management system.

Supported Browsers for Websites

Generally, the browser support level for sites is depending on the implementation of the templates, design and component output, and therefore in control of the party implementing these parts.

Note

Some browser-related exceptions for mobile clients are as listed below. These exceptions are only for AEM Forms:

  • HTML5 Forms does not support default Android browser.
  • Mobile clients are supported only for HTML5 Forms and Forms Portal.
  • Forms Portal is supported on Safari on iPad only.
  • Blackberry browser supports only adaptive forms.

WebDAV Clients

Microsoft Windows 7+

To successfully connect with Microsoft Windows 7+ to an AEM instance that is not secured with SSL, basic authentication over unsecured network must be enabled in Windows. This requires a change in the Windows Registry of the WebClient:

  1. Locate the registry subkey:
    • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters
  2. Add the BasicAuthLevel registry entry to this subkey using a value of 2 or more.

See Microsoft Support KB 841215.

To improve responsivness of the WebDav Client under Windows - see Microsoft Support KB 2445570

Additional Platform Notes

This section provides special notes and more detailed information about running Adobe Experience Manager and its add-ons.

IPv4 and IPv6

All elements of Adobe Experience Manager (Instance, Dispatcher) can be installed in both IPv4 and IPv6 networks.

Operation is seamless as no special configuration is required, when needed you can simply specify an IP address using the format that is appropriate to your network type.

This means that when an IP address needs to be specified you can select (as required) from:

  • an IPv6 address
    for example http://[ab12::34c5:6d7:8e90:1234]:4502
  • an IPv4 address
    for example http://123.1.1.4:4502
  • a server name
    for example, http://www.yourserver.com:4502
  • the default case of localhost will be interpreted for both IPv4 and IPv6 network installations
    for example, http://localhost:4502

Requirements for Dynamic Media Add-on

With dynamic media enabled, the system also has additional technical requirements.

Dynamic Media is disabled by default. You can enable Dynamic Media.

Hardware

The following hardware requirements are applicable for both Linux and Windows:

  • Intel Xeon or AMD Opteron CPU with at least 4 cores
  • 16GB of RAM minimum

Linux

If you are using Dynamic Media on Linux, the following prerequisites need to be met: 

  • RedHat Enterprise 5 or CentOS 5.5 and later with latest fix patches
  • 64-bit Operating System
  • Swapping disabled (recommended)
  • SELinux disabled (See note that follows)

Note

If the locale is set such that LC_CTYPE is not equal to en_US.UTF-8, it will prevent dynamic media from working. To see what its value is type "locale" at the command prompt. If it not set to that, then set the LC_CTYPE environment variable to the empty string by typing "export LC_CTYPE=" before running AEM.

Note

Disabling SELinux: Image Serving does not work with SELinux turned on. This option is enabled by default. To remedy this issue, edit the /etc/selinux/config file and change the SELinux value from:

SELINUX=enforcing to SELINUX=disabled

Note

NUMA Architecture: Systems with processors featuring AMD64 and Intel EM64T are typically configured as non-uniform memory architecture (NUMA) platforms, which means that the kernel constructs multiple memory nodes at boot-time rather than constructing a single memory node.

The multiple node construct can result in memory exhaustion on one or more of the nodes before other nodes become exhausted. When memory exhaustion happens the kernel can decide to kill processes (for example, the Image Server or Platform Server) even though there is available memory.

Therefore, Adobe recommends that if you are running such a system that you turn off NUMA using the numa=off boot option to avoid the kernel killing these processes.

Note

Hostname of server must be resolvable: Make sure that the hostname of the server is resolvable to an IP address. If that is not possible, please add the fully qualified hostname and the IP address to /etc/hosts:

<ip address> <fully qualified hostname>

Windows

  • Microsoft Windows Server (2008 R2, 2012, 2012 R2)
  • Swap space equal to at least twice the amount of physical memory (RAM)

To use Dynamic Media on Windows, Microsoft Visual Studio 2010, 2013, and 2015 redistributables must be installed.

MacOS

  • 10.9.x and later
  • Only supported for trial and demo purposes

Requirements for AEM Forms PDF Generator

AEM Forms PDF Generator supports only English, French, German, and Japanese versions of the supported operating systems and applications.

In addition:

  • PDF Generator requires Acrobat DC to perform the conversion.
  • AEM Forms supports only 32-bit editions of supported software.
  • The OCR PDF (Searchable PDF), Optimize PDF, and Export PDF features are supported only on Microsoft Windows.

Product

Supported Formats for Conversion to PDF

Adobe® Acrobat® DC Pro

XPS, image formats (BMP, GIF, JPEG, JPG, TIF, TIFF, PNG, JPF, JPX, JP2, J2K, J2C, JPC), HTML, HTM, DWG, DXF, and DWF

Microsoft® Office 2013 DOC, DOCX, XLS, XLSX, PPT, PPTX, RTF, and TXT

Microsoft® Office 2010

DOC, DOCX, XLS, XLSX, PPT, PPTX, RTF, and TXT

OpenOffice 3.4

ODT, ODP, ODS, ODG, ODF, SXW, SXI, SXC, SXD, XLS, XLSX, DOC, DOCX, PPT, PPTX, image formats (BMP, GIF, JPEG, JPG, TIF, TIFF, PNG, JPF, JPX, JP2, J2K, J2C, JPC), HTML, HTM, RTF, and TXT

OpenOffice 3.3

ODT, ODP, ODS, ODG, ODF, SXW, SXI, SXC, SXD, DOC, DOCX, XLS, XLSX, PPT, PPTX, image formats (BMP, GIF, JPEG, JPG, TIF, TIFF, PNG, JPF, JPX, JP2, J2K, J2C, JPC), HTML, and HTM

Requirements for AEM Assets XMP metadata write-back

XMP write-back is supported and enabled for the following platforms and file formats:

Operating Systems

File Formats
  • JPEG
  • PNG
  • TIFF
  • PDF
  • INDD
  • AI
  • EPS

Requirements for AEM Screens Player

The AEM Screens Player 3 supports media player hardware with following Operating Systems:

  • Apple iOS 10.2 and newer
  • Apple OSX 10.11 and macOS 10.12
  • Google Android 4.4.2
  • Google Android 5.1.1 with updated Android System WebView Version 52+

 

Copyright, Licenses and Disclaimers

Please read the Copyright, Licenses and Disclaimers page for all details.

Any questions?

Have a question about this or any other AEM topic? Ask our Community.
Learn more about AEM topics on our help hub.
Was this helpful?

By submitting your feedback, you accept the Adobe Terms of Use.

Thank you for submitting your feedback.